package/liquid-dsp: bump version

Removed patches applied upstream:
c9d239490d
3055eb3da9

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Bernd Kuhls 2016-06-05 23:26:03 +02:00 committed by Thomas Petazzoni
parent 8defd9c730
commit 054b75dfa5
4 changed files with 2 additions and 86 deletions

View file

@ -1,45 +0,0 @@
From c9d239490d47d5dd3d7d7b8b7d9007171c5f60ce Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Sun, 11 Oct 2015 15:27:09 +0200
Subject: [PATCH] configure.ac: use AC_CONFIG_MACRO_DIR
Instead of having to explicitly pass -I./scripts when running aclocal,
use the AC_CONFIG_MACRO_DIR() macro in configure.ac. This allows to
use "autoreconf" normally, without any hacks.
Submitted upstream at https://github.com/jgaeddert/liquid-dsp/pull/15.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
bootstrap.sh | 2 +-
configure.ac | 1 +
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/bootstrap.sh b/bootstrap.sh
index 640e01d..eb4894e 100755
--- a/bootstrap.sh
+++ b/bootstrap.sh
@@ -27,7 +27,7 @@
#
rm -f config.cache aclocal.m4
-aclocal -I./scripts
+aclocal
autoconf
autoheader
#automake --foreign --add-missing
diff --git a/configure.ac b/configure.ac
index a9ad1d7..3b1ba68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,7 @@
AC_INIT([liquid-dsp],[1.2.0],[support@liquidsdr.org])
AC_CONFIG_SRCDIR([src/libliquid.c])
+AC_CONFIG_MACRO_DIR([scripts])
# permit auxiliary scripts directory (e.g. config.sub, config.guess, install-sh)
AC_CONFIG_AUX_DIR(scripts/)
--
2.6.1

View file

@ -1,39 +0,0 @@
From 3055eb3da9d0a202c1a975f7db0c8370a09a30bc Mon Sep 17 00:00:00 2001
From: "Joseph D. Gaeddert" <joseph@liquidsdr.org>
Date: Thu, 25 Feb 2016 17:47:07 -0500
Subject: [PATCH] math/poly: wrapping isnan in T_ABS to help compilation w/
certain gcc versions
This is an upstreamed patch backported from here:
https://github.com/jgaeddert/liquid-dsp/commit/3055eb3da9d0a202c1a975f7db0c8370a09a30bc
It fixes the following error:
src/math/src/poly.findroots.c: In function
'polyc_findroots_bairstow_recursion':
src/math/src/poly.findroots.c:305:9: error: non-floating-point argument
in call to function '__builtin_isnan'
if (isnan(du) || isnan(dv)) {
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---
src/math/src/poly.findroots.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/math/src/poly.findroots.c b/src/math/src/poly.findroots.c
index 21b5756..e000ee8 100644
--- a/src/math/src/poly.findroots.c
+++ b/src/math/src/poly.findroots.c
@@ -302,7 +302,7 @@ void POLY(_findroots_bairstow_recursion)(T * _p,
#endif
// adjust u, v
- if (isnan(du) || isnan(dv)) {
+ if (isnan(T_ABS(du)) || isnan(T_ABS(dv))) {
u *= 0.5f;
v *= 0.5f;
} else {
--
2.7.3

View file

@ -1,2 +1,2 @@
# Locally calculated
sha256 4b6dcb0846ed884c55984494adef721f910ac6f895174b31ec52138263842637 liquid-dsp-df5a459fa05dba4199c1299555891104cc1fdca7.tar.gz
sha256 d0f050b9d5137c43ba45a35b6c82bc8222eba86f772f4e2e46c91427647bb847 liquid-dsp-1191179b786703b3af20abf7e1404d91099b335d.tar.gz

View file

@ -4,7 +4,7 @@
#
################################################################################
LIQUID_DSP_VERSION = df5a459fa05dba4199c1299555891104cc1fdca7
LIQUID_DSP_VERSION = 1191179b786703b3af20abf7e1404d91099b335d
LIQUID_DSP_SITE = $(call github,jgaeddert,liquid-dsp,$(LIQUID_DSP_VERSION))
LIQUID_DSP_LICENSE = MIT
LIQUID_DSP_LICENSE_FILES = LICENSE