nmap: bump to version 7.70

Drop libssh2 configure test fix; the issue is fixed upstream.

Add license file hash.

Cc: Carlos Santos <casantos@datacom.ind.br>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Baruch Siach 2018-04-10 14:42:25 +03:00 committed by Thomas Petazzoni
parent 02fe101688
commit 0bad8db32b
3 changed files with 6 additions and 42 deletions

View file

@ -1,30 +0,0 @@
From ff629766dbd3b5e179330ba4f07fd7e3d8384ec0 Mon Sep 17 00:00:00 2001
From: Max Filippov <jcmvbkbc@gmail.com>
Date: Wed, 1 Nov 2017 15:30:40 +0100
Subject: [PATCH] configure.ac: fix AC_CHECK_HEADER call to test for libssh2
The -lm argument is passed as an argument to AC_CHECK_HEADER(), which
doesn't make sense. The intention was to pass it as the fifth
argument of AC_CHECK_LIB().
Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 3d00e164e..67db42e08 100644
--- a/configure.ac
+++ b/configure.ac
@@ -674,7 +674,7 @@ AC_HELP_STRING([--without-libssh2], [Compile without libssh2]),
AC_CHECK_LIB(ssh2, libssh2_version,
[have_libssh2=yes
LIBSSH2_INC=$with_libssh2/include
- LIBSSH2_LIB=$with_libssh2/lib])],,[-lm])
+ LIBSSH2_LIB=$with_libssh2/lib],,[-lm])])
LDFLAGS=$_ldflags
CPPFLAGS=$_cppflags
--
2.13.6

View file

@ -1,2 +1,4 @@
# From https://nmap.org/dist/sigs/nmap-7.60.tar.bz2.digest.txt
sha256 a8796ecc4fa6c38aad6139d9515dc8113023a82e9d787e5a5fb5fa1b05516f21 nmap-7.60.tar.bz2
# From https://nmap.org/dist/sigs/nmap-7.70.tar.bz2.digest.txt
sha256 847b068955f792f4cc247593aca6dc3dc4aae12976169873247488de147a6e18 nmap-7.70.tar.bz2
# Locally calculated
sha256 e013006fbdb7a7923e456e72272b115a5d722a3c6a372f27b5e8fcd282104651 COPYING

View file

@ -4,23 +4,15 @@
#
################################################################################
NMAP_VERSION = 7.60
NMAP_VERSION = 7.70
NMAP_SITE = https://nmap.org/dist
NMAP_SOURCE = nmap-$(NMAP_VERSION).tar.bz2
NMAP_DEPENDENCIES = libpcap host-autoconf
NMAP_DEPENDENCIES = libpcap
NMAP_CONF_OPTS = --without-liblua --without-zenmap \
--with-libdnet=included --with-liblinear=included
NMAP_LICENSE = GPL-2.0
NMAP_LICENSE_FILES = COPYING
# nmap doesn't autoreconf properly, so we just re-generate the
# top-level configure script, since we are patching configure.ac.
define NMAP_DO_AUTOCONF
(cd $(@D); $(HOST_DIR)/bin/autoconf)
endef
NMAP_PRE_CONFIGURE_HOOKS += NMAP_DO_AUTOCONF
# needed by libpcap
NMAP_LIBS_FOR_STATIC_LINK += `$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`