squeezelite: reformat existing patch as a Git formatted patch

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Thomas Petazzoni 2016-02-07 18:17:13 +01:00
parent d42de84a8f
commit 19bb96f076

View file

@ -1,12 +1,21 @@
From a0f2e79d1373967dac9f3df4c500a71cd1b96b2b Mon Sep 17 00:00:00 2001
From: Hiroshi Kawashima <kei-k@ca2.so-net.ne.jp>
Date: Sun, 7 Feb 2016 18:04:53 +0100
Subject: [PATCH] Makefile: allow passing CFLAGS and LDFLAGS
This patch is applied to squeezelite Makefile to add override
directive for CFLAGS and LDFLAGS assignment.
This enables adding flags to CFLAGS and LDFLAGS in Makefile.
Signed-off-by: Hiroshi Kawashima <kei-k@ca2.so-net.ne.jp>
---
Makefile | 12 +++++++-----
1 file changed, 7 insertions(+), 5 deletions(-)
diff -ruN a/Makefile b/Makefile
--- a/Makefile 2015-02-01 23:56:21.000000000 +0900
+++ b/Makefile 2015-09-29 20:06:52.268069187 +0900
diff --git a/Makefile b/Makefile
index dca2abd..286c725 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,6 @@
# Cross compile support - create a Makefile which defines these three variables and then includes this Makefile...
+override CFLAGS += $(OPTS)
@ -14,7 +23,7 @@ diff -ruN a/Makefile b/Makefile
CFLAGS ?= -Wall -fPIC -O2 $(OPTS)
LDFLAGS ?= -lasound -lpthread -lm -lrt
EXECUTABLE ?= squeezelite
@@ -52,20 +54,20 @@
@@ -52,20 +54,20 @@ endif
# add optional link options
ifneq (,$(findstring $(OPT_LINKALL), $(CFLAGS)))
@ -40,3 +49,6 @@ diff -ruN a/Makefile b/Makefile
endif
endif
--
2.6.4