package/ltp-testsuite: bump version to 20230127

Backport mount_attr fix for glibc-based toolchain.

Fixes:
 - http://autobuild.buildroot.org/results/4dbb72e1bf081afd3cd944571b9beeefc7608865

Signed-off-by: Petr Vorel <petr.vorel@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
2023.05.x
Petr Vorel 2023-04-16 22:17:05 +02:00 committed by Yann E. MORIN
parent 5e1c238b72
commit 1ace31aec5
3 changed files with 57 additions and 4 deletions

View File

@ -0,0 +1,54 @@
From 30353a1eb3ee8940f38d6a0e8f5f39352fd8a179 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 26 Feb 2023 20:25:54 +0100
Subject: [PATCH] configure.ac: fix mount_attr detection
Upstream: https://github.com/linux-test-project/ltp/commit/30353a1eb3ee8940f38d6a0e8f5f39352fd8a179
Commit b857f8723f30a4b9554bf6b0ff8fa52fd07e8b60 tried to fix build with
latest glibc which provides mount_attr in sys/mount.h. Unfortunately,
the following build failure is still raised because sys/mount is now
unconditionally included in include/lapi/fsmount.h:
In file included from fsconfig01.c:9:
../../../../include/lapi/fsmount.h:55:8: error: redefinition of 'struct mount_attr'
55 | struct mount_attr {
| ^~~~~~~~~~
In file included from ../../../../include/lapi/fsmount.h:14:
/home/autobuild/autobuild/instance-4/output-1/host/armeb-buildroot-linux-gnueabi/sysroot/usr/include/sys/mount.h:210:8: note: originally defined here
210 | struct mount_attr
| ^~~~~~~~~~
Fixes: b857f8723 ("lapi/fsmount: resolve conflict in different header files")
Fixes: http://autobuild.buildroot.org/results/4dbb72e1bf081afd3cd944571b9beeefc7608865
Link: https://lore.kernel.org/ltp/20230226192554.669332-1-fontaine.fabrice@gmail.com/
Reviewed-by: Li Wang <liwang@redhat.com>
[ pvorel: fix from b857f8723 is needed for glibc before glibc-2.37~426,
i.e. without fix 774058d729 ("linux: Fix sys/mount.h usage with kernel headers")
(which was backported to 2.35 and 2.34 maintenance). ]
Reviewed-by: Petr Vorel <pvorel@suse.cz>
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
configure.ac | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index 114468ae3..4c8763376 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,10 +224,10 @@ AC_CHECK_TYPES([struct __kernel_old_timeval, struct __kernel_old_timespec, struc
AC_CHECK_TYPES([struct futex_waitv],,,[#include <linux/futex.h>])
AC_CHECK_TYPES([struct mount_attr],,,[
-#ifdef HAVE_LINUX_MOUNT_H
-# include <linux/mount.h>
-#else
+#ifdef HAVE_MOUNT_SETATTR
# include <sys/mount.h>
+#elif HAVE_LINUX_MOUNT_H
+# include <linux/mount.h>
#endif
])
--
2.40.0

View File

@ -1,5 +1,4 @@
# From: https://github.com/linux-test-project/ltp/releases/download/20220527/ltp-full-20220527.tar.bz2.sha1
sha1 c8d658cd3ab1f5a5c7b5bf56398d3a9525012c6b ltp-full-20220930.tar.xz
# From: https://github.com/linux-test-project/ltp/releases/download/20230127/ltp-full-20230127.tar.xz.sha256
sha256 254412a52c7238f35a247337da186f485e76fb64c6549ed849b3442fc7a417ef ltp-full-20230127.tar.xz
# Locally computed
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
sha256 533ab63915b916640667ecce17ee4998006d80d394d4b1f1d105a7aa1df50d38 ltp-full-20220930.tar.xz

View File

@ -4,7 +4,7 @@
#
################################################################################
LTP_TESTSUITE_VERSION = 20220930
LTP_TESTSUITE_VERSION = 20230127
LTP_TESTSUITE_SOURCE = ltp-full-$(LTP_TESTSUITE_VERSION).tar.xz
LTP_TESTSUITE_SITE = https://github.com/linux-test-project/ltp/releases/download/$(LTP_TESTSUITE_VERSION)