package/liboping: fix build after bump

Fixes:
    http://autobuild.buildroot.org/results/6a9/6a9b4d7b1b3cd72e32579fbaf5a69dbde0fea8e4/

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Yann E. MORIN 2016-07-05 16:32:29 +02:00 committed by Thomas Petazzoni
parent 0e68543195
commit 246c991891
2 changed files with 41 additions and 0 deletions

View file

@ -0,0 +1,39 @@
From a45f3610beba1f7e6e1a038e3a1fe4150057c262 Mon Sep 17 00:00:00 2001
From: "Yann E. MORIN" <yann.morin.1998@free.fr>
Date: Tue, 5 Jul 2016 15:31:28 +0200
Subject: [PATCH] configure: also check for clockgettime()
clock_gettime() is also in -lrt so we also need to check for it.
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
configure.ac | 10 +++++++---
1 file changed, 7 insertions(+), 3 deletions(-)
diff --git a/configure.ac b/configure.ac
index f83f5ab..3b6ae09 100644
--- a/configure.ac
+++ b/configure.ac
@@ -199,12 +199,16 @@ fi
AC_SUBST(LIBOPING_PC_LIBS_PRIVATE)
-nanosleep_needs_rt="no"
+needs_rt="no"
AC_CHECK_FUNCS(nanosleep, [],
AC_CHECK_LIB(rt, nanosleep,
- [nanosleep_needs_rt="yes"],
+ [needs_rt="yes"],
AC_MSG_ERROR(cannot find nanosleep)))
-AM_CONDITIONAL(BUILD_WITH_LIBRT, test "x$nanosleep_needs_rt" = "xyes")
+AC_CHECK_FUNCS(clock_gettime, [],
+ AC_CHECK_LIB(rt, clock_gettime,
+ [needs_rt="yes"],
+ AC_MSG_ERROR(cannot find clock_gettime)))
+AM_CONDITIONAL(BUILD_WITH_LIBRT, test "x$needs_rt" = "xyes")
with_ncurses="no"
AC_CHECK_HEADERS(ncursesw/ncurses.h ncurses.h, [with_ncurses="yes"], [])
--
2.7.4

View file

@ -13,4 +13,6 @@ LIBOPING_CONF_OPTS = --without-perl-bindings
LIBOPING_LICENSE = LGPLv2.1+, GPLv2
LIBOPING_LICENSE_FILES = COPYING
LIBOPING_AUTORECONF = YES
$(eval $(autotools-package))