package/haveged: bump to version 1.9.15

Drop patch (already in version) and so autoreconf

https://github.com/jirka-h/haveged/releases/tag/v1.9.15

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Fabrice Fontaine 2021-12-15 00:14:57 +01:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 8de5996e5c
commit 2a28d25d0c
3 changed files with 2 additions and 64 deletions

View file

@ -1,60 +0,0 @@
From 676abde95bab10e1d26e91682772514010143343 Mon Sep 17 00:00:00 2001
From: Peter Seiderer <ps.report@gmx.net>
Date: Sun, 21 Mar 2021 17:00:08 +0100
Subject: [PATCH] Check for sys/auxv.h before using it.
- fixes uclibc-ng compile (does not provide sys/auxv.h header file)
Fixes:
haveged.c:22:10: fatal error: sys/auxv.h: No such file or directory
22 | #include <sys/auxv.h>
| ^~~~~~~~~~~~
[Upstream: https://github.com/jirka-h/haveged/pull/59]
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
configure.ac | 1 +
src/haveged.c | 4 ++++
2 files changed, 5 insertions(+)
diff --git a/configure.ac b/configure.ac
index c172a10..a0263f5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -125,6 +125,7 @@ AC_CHECK_HEADERS(stdio.h)
AC_CHECK_HEADERS(stdlib.h)
AC_CHECK_HEADERS(string.h)
AC_CHECK_HEADERS(sys/ioctl.h)
+AC_CHECK_HEADERS(sys/auxv.h)
AC_CHECK_HEADERS(sys/mman.h)
AC_CHECK_HEADERS(sys/types.h)
AC_CHECK_HEADERS(sys/socket.h)
diff --git a/src/haveged.c b/src/haveged.c
index b9cb77b..dad3072 100644
--- a/src/haveged.c
+++ b/src/haveged.c
@@ -19,7 +19,9 @@
** along with this program. If not, see <http://www.gnu.org/licenses/>.
*/
#include "config.h"
+#if defined(HAVE_SYS_AUXV_H)
#include <sys/auxv.h>
+#endif
#include <stdlib.h>
#include <stdio.h>
#include <getopt.h>
@@ -135,8 +137,10 @@ int main(int argc, char **argv)
{
volatile char *path = strdup(argv[0]);
volatile char *arg0 = argv[0];
+#if defined(HAVE_SYS_AUXV_H)
if (path[0] != '/')
path = (char*)getauxval(AT_EXECFN);
+#endif
static const char* cmds[] = {
"b", "buffer", "1", SETTINGR("Buffer size [KW], default: ",COLLECT_BUFSIZE),
"d", "data", "1", SETTINGR("Data cache size [KB], with fallback to: ", GENERIC_DCACHE ),
--
2.30.2

View file

@ -1,3 +1,3 @@
# Locally calculated
sha256 938cb494bcad7e4f24e61eb50fab4aa0acbc3240c80f3ad5c6cf7e6e922618c3 haveged-1.9.14.tar.gz
sha256 f882919ccead07ad6687a4784c0c501e617321e96dd0118403464969359cf6ad haveged-1.9.15.tar.gz
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING

View file

@ -4,13 +4,11 @@
#
################################################################################
HAVEGED_VERSION = 1.9.14
HAVEGED_VERSION = 1.9.15
HAVEGED_SITE = $(call github,jirka-h,haveged,v$(HAVEGED_VERSION))
HAVEGED_LICENSE = GPL-3.0+
HAVEGED_LICENSE_FILES = COPYING
HAVEGED_SELINUX_MODULES = entropyd
# patch touching configure.ac
HAVEGED_AUTORECONF = YES
# '--disable-init' as buildroot ships its own sysv/systemd init files
HAVEGED_CONF_OPTS = \