package/libpsl: bump to version 0.21.2

- Drop patch (already in version)
- Update hash of COPYING (update in year:
  927b202c69)
- builtin is a boolean since
  aa4909766c

https://github.com/rockdaboot/libpsl/releases/tag/0.21.2

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Adrian Perez de Castro <aperez@igalia.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2023.02.x
Fabrice Fontaine 2023-01-14 18:54:46 +01:00 committed by Peter Korsgaard
parent 1e3d5b7c6d
commit 33703b32bf
3 changed files with 7 additions and 66 deletions

View File

@ -1,60 +0,0 @@
From 5b63816e82287808e81b8603a528af3cc6fab354 Mon Sep 17 00:00:00 2001
From: Zhao Zhili <zhilizhao@tencent.com>
Date: Thu, 7 Jan 2021 20:59:17 +0800
Subject: [PATCH] Add libiconv dep to meson build again
Build success on macOS and ubuntu.
[Retrieved from:
https://github.com/rockdaboot/libpsl/commit/5b63816e82287808e81b8603a528af3cc6fab354]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
meson.build | 14 ++++++++++++++
src/meson.build | 2 +-
2 files changed, 15 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index f248171..fb2de31 100644
--- a/meson.build
+++ b/meson.build
@@ -20,6 +20,7 @@ libicu_dep = notfound
libidn_dep = notfound
libunistring = notfound
networking_deps = notfound
+libiconv_dep = notfound
# FIXME: Cleanup this when Meson gets 'feature-combo':
# https://github.com/mesonbuild/meson/issues/4566
@@ -86,6 +87,19 @@ endif
if libidn2_dep.found() or libidn_dep.found()
# Check for libunistring, we need it for psl_str_to_utf8lower()
libunistring = cc.find_library('unistring')
+ found_iconv = false
+ if cc.has_function('iconv_open')
+ libiconv_dep = []
+ found_iconv = true
+ endif
+ if not found_iconv and cc.has_header_symbol('iconv.h', 'iconv_open')
+ libiconv_dep = [cc.find_library('iconv')]
+ found_iconv = true
+ endif
+
+ if not found_iconv
+ error('iconv implementation not found')
+ endif
endif
if host_machine.system() == 'windows'
diff --git a/src/meson.build b/src/meson.build
index 0d1dcdf..746bf44 100644
--- a/src/meson.build
+++ b/src/meson.build
@@ -19,7 +19,7 @@ cargs = [
libpsl = library('psl', sources, suffixes_dafsa_h,
include_directories : [configinc, includedir],
c_args : cargs,
- dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps],
+ dependencies : [libidn2_dep, libidn_dep, libicu_dep, libunistring, networking_deps, libiconv_dep],
version: lt_version,
install: true,
)

View File

@ -1,6 +1,6 @@
# Locally generated
sha256 ac6ce1e1fbd4d0254c4ddb9d37f1fa99dec83619c1253328155206b896210d4c libpsl-0.21.1.tar.gz
sha256 e35991b6e17001afa2c0ca3b10c357650602b92596209b7492802f3768a6285f libpsl-0.21.2.tar.gz
# Hashes for license files:
sha256 7903413e7aa0bbcb77aa19150a3f1034edc0a760cff174f9a53efe4de6f056a4 COPYING
sha256 776cd11d54f0ea3e5efdd25ff1a0d952a1744215bb5858ea7aeb91808e70c9f7 COPYING
sha256 1d7f52747a9169751cdf2641a8299c0098e9ecdf9429296ffd55bdb14c9ed5b3 src/LICENSE.chromium

View File

@ -4,10 +4,11 @@
#
################################################################################
LIBPSL_VERSION = 0.21.1
LIBPSL_VERSION = 0.21.2
LIBPSL_SITE = https://github.com/rockdaboot/libpsl/releases/download/$(LIBPSL_VERSION)
LIBPSL_LICENSE = MIT, BSD-3-Clause
LIBPSL_LICENSE_FILES = COPYING src/LICENSE.chromium
LIBPSL_CONF_OPTS = -Dbuiltin=true
LIBPSL_DEPENDENCIES = host-pkgconf
LIBPSL_INSTALL_STAGING = YES
@ -17,13 +18,13 @@ endif
# The order of checks is the same as done by libpsl when configured.
ifeq ($(BR2_PACKAGE_LIBIDN2)$(BR2_PACKAGE_LIBUNISTRING),yy)
LIBPSL_CONF_OPTS += -Druntime=libidn2 -Dbuiltin=libidn2
LIBPSL_CONF_OPTS += -Druntime=libidn2
LIBPSL_DEPENDENCIES += libidn2 libunistring
else ifeq ($(BR2_PACKAGE_ICU),y)
LIBPSL_CONF_OPTS += -Druntime=libicu -Dbuiltin=libicu
LIBPSL_CONF_OPTS += -Druntime=libicu
LIBPSL_DEPENDENCIES += icu
else
LIBPSL_CONF_OPTS += -Druntime=libidn -Dbuiltin=libidn
LIBPSL_CONF_OPTS += -Druntime=libidn
LIBPSL_DEPENDENCIES += libidn libunistring
endif