package/mbw: bump to version 2.0

This new version is released under GPL-3.0. The patch can be removed
as it has been accepted upstream as of commit
86a38c688a.

Signed-off-by: Guillaume W. Bres <guillaume.bressaix@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
master
Guillaume W. Bres 2023-05-21 10:20:32 +02:00 committed by Thomas Petazzoni
parent a433fbcff7
commit 39610c8b3c
4 changed files with 5 additions and 44 deletions

View File

@ -933,7 +933,6 @@ package/matchbox-panel/0003-mb-applet-battery.patch Upstream
package/matchbox-startup-monitor/0001-true-false.patch Upstream
package/matchbox/0001-defaulttheme.patch Upstream
package/matchbox/0002-src-Fix-build-with-gcc-10.patch Upstream
package/mbw/0001-CMakeLists.txt-fix-build-without-C.patch Upstream
package/mediastreamer/0001-src-videofilters-nowebcam.c-fix-build-without-ffmpeg.patch Upstream
package/mediastreamer/0002-Use-AV_INPUT_BUFFER_PADDING_SIZE-to-determine-paddin.patch Upstream
package/memcached/0001-logger.c-initialize-rport.patch Upstream

View File

@ -1,38 +0,0 @@
From 059f67459912bba6d7f605b7c43519ff547f3a80 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 7 Aug 2022 11:34:19 +0200
Subject: [PATCH] CMakeLists.txt: fix build without C++
Fix the following build failure without C++:
CMake Error at CMakeLists.txt:3 (project):
No CMAKE_CXX_COMPILER could be found.
Tell CMake where to find the compiler by setting either the environment
variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
to the compiler, or to the compiler name if it is in the PATH.
Fixes:
- http://autobuild.buildroot.org/results/17e2d6e6d6ddf7845a37a8bbf733faf40d9faa61
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/raas/mbw/pull/14]
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d3d4fcd..3b2cb3e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 3.10)
-project(mbw VERSION 1.5)
+project(mbw VERSION 1.5 LANGUAGES C)
add_executable(mbw mbw.c)
install(TARGETS mbw DESTINATION bin)
--
2.35.1

View File

@ -1,3 +1,3 @@
# Locally computed
sha256 3c396ce09bb78c895e4d45e99b1ae07f80e3ea5eee59d78ed2048a7f2ae591ae mbw-1.5.tar.gz
sha256 1afb2b8258506742238b9ceb8a865d7030c5889c56ba2911a0c0c042aa1335d1 mbw.spec
sha256 557f670e13ff663086fe239e4184d8ca6154b004bd5fde2b0a748e5aa543c87f mbw-2.0.tar.gz
sha256 3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986 LICENSE

View File

@ -4,9 +4,9 @@
#
################################################################################
MBW_VERSION = 1.5
MBW_VERSION = 2.0
MBW_SITE = $(call github,raas,mbw,v$(MBW_VERSION))
MBW_LICENSE = LGPL-2.1
MBW_LICENSE_FILES = mbw.spec
MBW_LICENSE = GPL-3.0+
MBW_LICENSE_FILES = LICENSE
$(eval $(cmake-package))