fcgiwrap: Add a patch to link with libsystemd, not libsystemd-daemon.

Fixes:

  http://autobuild.buildroot.org/results/9b5e70e42e53e7752245f7c43bd01f208fcf76d0/

Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Thomas Claveirole 2016-07-18 16:28:50 +02:00 committed by Thomas Petazzoni
parent 2158843582
commit 3dbd99c0d7

View file

@ -0,0 +1,20 @@
configure.ac: Check for libsystemd, not libsystemd-daemon.
Newer versions of systemd do not provide libsystemd-daemon anymore.
Therefore, use libsystemd instead.
Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
diff --git a/configure.ac b/configure.ac
index bb3674e..2b02ef4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,7 +28,7 @@ AC_ARG_WITH([systemd],
[], [with_systemd=check])
have_systemd=no
if test "x$with_systemd" != "xno"; then
- PKG_CHECK_MODULES(systemd, [libsystemd-daemon],
+ PKG_CHECK_MODULES(systemd, [libsystemd],
[AC_DEFINE(HAVE_SYSTEMD, 1, [Define if systemd is available])
have_systemd=yes],
have_systemd=no)