tmux: bump to 2.0

Add new location as tmux moved to GitHub.

Remove the patch as it was already merged upstream.
Remove related AUTORECONF as well.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Yegor Yefremov 2015-06-17 21:28:21 +02:00 committed by Thomas Petazzoni
parent fc0345a9a2
commit 3e7904ac72
3 changed files with 3 additions and 41 deletions

View file

@ -1,35 +0,0 @@
From 4095ee95141063ff3f91153e84bd029b019b8dad Mon Sep 17 00:00:00 2001
From: Romain Naour <romain.naour@openwide.fr>
Date: Fri, 26 Dec 2014 17:44:15 +0100
Subject: [PATCH] Makefile.am: remove unsafe headers path
/usr/local/include is probably not needed and it's unsafe for
cross-compilation.
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
---
Makefile.am | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index a9ad5b9..0109e5d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,12 +38,12 @@ else
CFLAGS += -O2
endif
if IS_GCC4
-CPPFLAGS += -iquote. -I/usr/local/include
+CPPFLAGS += -iquote.
if IS_DEBUG
CFLAGS += -Wno-pointer-sign
endif
else
-CPPFLAGS += -I. -I- -I/usr/local/include
+CPPFLAGS += -I. -I-
endif
endif
--
1.9.3

View file

@ -1,2 +1,2 @@
# Locally computed:
sha256 c5e3b22b901cf109b20dab54a4a651f0471abd1f79f6039d79b250d21c2733f5 tmux-1.9a.tar.gz
sha256 795f4b4446b0ea968b9201c25e8c1ef8a6ade710ebca4657dd879c35916ad362 tmux-2.0.tar.gz

View file

@ -4,13 +4,10 @@
#
################################################################################
TMUX_VERSION = 1.9a
TMUX_SITE = http://downloads.sourceforge.net/tmux
TMUX_VERSION = 2.0
TMUX_SITE = https://github.com/tmux/tmux/releases/download/$(TMUX_VERSION)
TMUX_LICENSE = ISC
TMUX_LICENSE_FILES = README
TMUX_DEPENDENCIES = libevent ncurses host-pkgconf
# we patch Makefile.am
TMUX_AUTORECONF = YES
$(eval $(autotools-package))