package/olsr: bump to version 0.9.8

- Upstream no longer pushes tarballs to their release directory, so
  switch to github, which has the latest releases
- Drop patch (already in version)
- Add poprouting plugin (added in version 0.9.7 with
  316901040f)
- Add hash for license files

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Fabrice Fontaine 2020-01-18 14:57:08 +01:00 committed by Yann E. MORIN
parent 4c8a285b6e
commit 4929c54531
3 changed files with 7 additions and 40 deletions

View file

@ -1,33 +0,0 @@
Make ldconfig configurable
In a cross-compilation set up, running /sbin/ldconfig is useless, so
we make the path to ldconfig configurable through the environment/make
command line. This allows to pass LDCONFIG=/bin/true when doing
cross-compilation.
[Gustavo: update patch for olsr 0.6.4]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
diff -Nura olsrd-0.6.4.orig/make/Makefile.linux olsrd-0.6.4/make/Makefile.linux
--- olsrd-0.6.4.orig/make/Makefile.linux 2013-01-29 09:00:18.041356389 -0300
+++ olsrd-0.6.4/make/Makefile.linux 2013-01-29 09:01:51.598226624 -0300
@@ -3,6 +3,7 @@
#
ARCH := $(shell uname -m)
+LDCONFIG ?= /sbin/ldconfig
DESTDIR ?=
prefix ?= /usr/local
@@ -26,9 +27,9 @@
PLUGIN_SONAME ?= lib$(PLUGIN_NAME).so
PLUGIN_FULLNAME ?= $(PLUGIN_NAME).so.$(PLUGIN_VER)
INSTALL_LIB = install -D -m 755 $(PLUGIN_FULLNAME) $(LIBDIR)/$(PLUGIN_FULLNAME); \
- /sbin/ldconfig -n $(LIBDIR)
+ $(LDCONFIG) -n $(LIBDIR)
UNINSTALL_LIB = rm -f $(LIBDIR)/$(PLUGIN_FULLNAME); \
- /sbin/ldconfig -n $(LIBDIR)
+ $(LDCONFIG) -n $(LIBDIR)
ifdef OLSRD_PLUGIN
GENERATE_PIC = true

View file

@ -1,2 +1,4 @@
# From http://www.olsr.org/releases/0.9/SHA256SUM-0.9.6.1
sha256 9cac290e9bff5fc7422110b9ccd972853f10962c962d2f31a63de9c6d1520612 olsrd-0.9.6.1.tar.bz2
# Locally computed
sha256 ee9e524224e5d5304dcf61f1dc5485c569da09d382934ff85b233be3e24821a3 olsr-0.9.8.tar.gz
sha256 7dcf1fb93ef105e2708b02603bb6ee443115d4819fbf2c5a3a001b46887acb9a license.txt
sha256 dc626520dcd53a22f727af3ee42c770e56c97a64fe3adb063799d8ab032fe551 lib/pud/nmealib/LICENSE

View file

@ -4,12 +4,10 @@
#
################################################################################
OLSR_VERSION_MAJOR = 0.9
OLSR_VERSION = $(OLSR_VERSION_MAJOR).6.1
OLSR_SOURCE = olsrd-$(OLSR_VERSION).tar.bz2
OLSR_SITE = http://www.olsr.org/releases/$(OLSR_VERSION_MAJOR)
OLSR_VERSION = 0.9.8
OLSR_SITE = $(call github,OLSR,olsrd,v$(OLSR_VERSION))
OLSR_PLUGINS = arprefresh bmf dot_draw dyn_gw dyn_gw_plain httpinfo jsoninfo \
mdns nameservice netjson p2pd pgraph secure txtinfo watchdog
mdns nameservice netjson poprouting p2pd pgraph secure txtinfo watchdog
# Doesn't really need quagga but not very useful without it
OLSR_PLUGINS += $(if $(BR2_PACKAGE_QUAGGA),quagga)
OLSR_LICENSE = BSD-3-Clause, LGPL-2.1+