package/gst1-rtsp-server: bump version to 1.18.0

- change home page url to https

- remove 0001-meson-build-gir-even-when-cross-compiling-if-introspection.patch
  (upstream [1])

- meson options: doc=disabled

[1] 95ce953e34.patch

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Peter Seiderer 2020-09-16 21:49:31 +02:00 committed by Thomas Petazzoni
parent 3f98c491e8
commit 552347484f
4 changed files with 8 additions and 43 deletions

View file

@ -1,36 +0,0 @@
From 35db4a2433fbdf8612cf98b5aab5b14aeb5372f8 Mon Sep 17 00:00:00 2001
From: Tim Philipp <tim@centricular.com>
Date: Fri, 18 Oct 2019 00:42:12 +0100
Subject: [PATCH] meson: build gir even when cross-compiling if introspection
was enabled explicitly
This can be made to work in certain circumstances when
cross-compiling, so default to not building g-i stuff
when cross-compiling, but allow it if introspection was
enabled explicitly via -Dintrospection=enabled.
See gstreamer/gstreamer#454 and gstreamer/gstreamer#381.
Upstream commit: 95ce953e34cd0e9f5d42ce7900a9572e7bc8ca47
Signed-off-by: Tim Philipp <tim@centricular.com>
Signed-off-by: Adam Duskett <aduskett@gmail.com>
---
meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index e1e3b1d..3f45f0e 100644
--- a/meson.build
+++ b/meson.build
@@ -173,7 +173,7 @@ endif
gir = find_program('g-ir-scanner', required : get_option('introspection'))
gnome = import('gnome')
-build_gir = gir.found() and not meson.is_cross_build()
+build_gir = gir.found() and (not meson.is_cross_build() or get_option('introspection').enabled())
gir_init_section = [ '--add-init-section=extern void gst_init(gint*,gchar**);' + \
'g_setenv("GST_REGISTRY_1.0", "@0@", TRUE);'.format(meson.current_build_dir() + '/gir_empty_registry.reg') + \
'g_setenv("GST_PLUGIN_PATH_1_0", "", TRUE);' + \
--
2.24.1

View file

@ -9,4 +9,4 @@ config BR2_PACKAGE_GST1_RTSP_SERVER
help
RTSP server library based on GStreamer.
http://gstreamer.freedesktop.org/
https://gstreamer.freedesktop.org/

View file

@ -1,4 +1,4 @@
# From https://gstreamer.freedesktop.org/src/gst-rtsp-server/gst-rtsp-server-1.16.2.tar.xz.sha256sum
sha256 de07a2837b3b04820ce68264a4909f70c221b85dbff0cede7926e9cdbb1dc26e gst-rtsp-server-1.16.2.tar.xz
sha256 f445dc78b88496f7e20c7a2a461b95baba5865c8919b8289ac24ac0a80c6ce7a COPYING
sha256 f445dc78b88496f7e20c7a2a461b95baba5865c8919b8289ac24ac0a80c6ce7a COPYING.LIB
# From https://gstreamer.freedesktop.org/src/gst-rtsp-server/gst-rtsp-server-1.18.0.tar.xz.sha256sum
sha256 2ad19311054cbf2df0d0622936bc703dedc06ced706df46a3d3a3ea5a4b7c70f gst-rtsp-server-1.18.0.tar.xz
sha256 f445dc78b88496f7e20c7a2a461b95baba5865c8919b8289ac24ac0a80c6ce7a COPYING
sha256 f445dc78b88496f7e20c7a2a461b95baba5865c8919b8289ac24ac0a80c6ce7a COPYING.LIB

View file

@ -4,7 +4,7 @@
#
################################################################################
GST1_RTSP_SERVER_VERSION = 1.16.2
GST1_RTSP_SERVER_VERSION = 1.18.0
GST1_RTSP_SERVER_SOURCE = gst-rtsp-server-$(GST1_RTSP_SERVER_VERSION).tar.xz
GST1_RTSP_SERVER_SITE = http://gstreamer.freedesktop.org/src/gst-rtsp-server
GST1_RTSP_SERVER_LICENSE = LGPL-2.0+
@ -20,7 +20,8 @@ GST1_RTSP_SERVER_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
GST1_RTSP_SERVER_CONF_OPTS = \
-Dexamples=disabled \
-Dtests=disabled
-Dtests=disabled \
-Ddoc=disabled
GST1_RTSP_SERVER_CONF_OPTS += \
-Dexamples=disabled \