package/sslh: bump to version 1.22c

- pcre2 is mandatory since version 1.22b and
  37d2756703
- Drop patch (not needed anymore)

https://github.com/yrutschle/sslh/blob/v1.22c/ChangeLog

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
This commit is contained in:
Fabrice Fontaine 2021-12-30 23:52:04 +01:00 committed by Yann E. MORIN
parent 663f39c88c
commit 5b9c58531e
4 changed files with 4 additions and 50 deletions

View file

@ -1,41 +0,0 @@
From 0d9e004d324cc030c173de04c40db51a0f22bb5c Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Thu, 15 Oct 2020 07:58:05 +0200
Subject: [PATCH] Makefile: fix static linking with pcre
Static build with pcre is broken since version 1.19b and
https://github.com/yrutschle/sslh/commit/cb90cc97ae64a445242e517847c6e44b7003eda4
because -lpcre has been replaced by -lpcreposix which will result in
the following static build failure:
/srv/storage/autobuild/run/instance-1/output-1/host/bin/mipsel-linux-gcc -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Os -static -static -o echosrv echosrv.o probe.o common.o tls.o -lpcreposix -lconfig -lcap
/srv/storage/autobuild/run/instance-1/output-1/host/opt/ext-toolchain/bin/../lib/gcc/mipsel-buildroot-linux-uclibc/8.3.0/../../../../mipsel-buildroot-linux-uclibc/bin/ld: /srv/storage/autobuild/run/instance-1/output-1/host/mipsel-buildroot-linux-uclibc/sysroot/usr/lib/libpcreposix.a(libpcreposix_la-pcreposix.o): in function `regfree':
pcreposix.c:(.text+0x120): undefined reference to `pcre_free'
So append -lpcre after -lpcreposix
Fixes:
- http://autobuild.buildroot.org/results/a601824fc0c205a6a940e0f9f079ce2c39840605
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/yrutschle/sslh/pull/280]
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index 986cf1c..ecadc22 100644
--- a/Makefile
+++ b/Makefile
@@ -43,7 +43,7 @@ endif
ifneq ($(strip $(USELIBPCRE)),)
CPPFLAGS+=-DLIBPCRE
- LIBS:=$(LIBS) -lpcreposix
+ LIBS:=$(LIBS) -lpcreposix -lpcre
endif
ifneq ($(strip $(USELIBCONFIG)),)
--
2.28.0

View file

@ -2,6 +2,7 @@ config BR2_PACKAGE_SSLH
bool "sslh"
depends on BR2_USE_MMU # fork()
select BR2_PACKAGE_LIBCONFIG if BR2_PACKAGE_SYSTEMD
select BR2_PACKAGE_PCRE2
help
Applicative protocol multiplexer

View file

@ -1,3 +1,3 @@
# Locally calculated
sha256 3bfe783726f82c1f5a4be630ddc494ebb08dbb69980662cd7ffdeb7bc9e1e706 sslh-v1.21c.tar.gz
sha256 8e3742d14edf4119350cfdc7bb96b89134d9218eb6d2a6e1f70891ca18a649b1 sslh-v1.22c.tar.gz
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING

View file

@ -4,11 +4,12 @@
#
################################################################################
SSLH_VERSION = 1.21c
SSLH_VERSION = 1.22c
SSLH_SOURCE = sslh-v$(SSLH_VERSION).tar.gz
SSLH_SITE = http://www.rutschle.net/tech/sslh
SSLH_LICENSE = GPL-2.0+
SSLH_LICENSE_FILES = COPYING
SSLH_DEPENDENCIES = pcre2
SSLH_MAKE_OPTS = $(TARGET_CONFIGURE_OPTS)
@ -33,13 +34,6 @@ else
SSLH_MAKE_OPTS += USELIBCONFIG=
endif
ifeq ($(BR2_PACKAGE_PCRE),y)
SSLH_DEPENDENCIES += pcre
SSLH_MAKE_OPTS += USELIBPCRE=1
else
SSLH_MAKE_OPTS += USELIBPCRE=
endif
ifeq ($(BR2_PACKAGE_SYSTEMD),y)
SSLH_DEPENDENCIES += systemd
SSLH_MAKE_OPTS += USESYSTEMD=1