bctoolbox: fix typos and logic error

To get the directory path from the library name you need to
use a single filename. Fix typo in variable name.

This fixes the ortp autobuild errors which uses the broken pkgconfig file
from bctoolbox.

Fixes:
  http://autobuild.buildroot.net/results/37d5625df4be11ccdc063871e9f6e13d5f59fb52
  http://autobuild.buildroot.net/results/1999c841fae41f860f00747a362327cb2857e687

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Waldemar Brodkorb 2017-02-14 10:01:32 +01:00 committed by Peter Korsgaard
parent 8b8b4f7bfe
commit 5c4d3560b9

View file

@ -0,0 +1,18 @@
Fix a typo in the variable name. Only check path for a single library name.
Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
diff -Nur bctoolbox-0.4.0.orig/CMakeLists.txt bctoolbox-0.4.0/CMakeLists.txt
--- bctoolbox-0.4.0.orig/CMakeLists.txt 2016-10-06 17:30:41.000000000 +0200
+++ bctoolbox-0.4.0/CMakeLists.txt 2017-02-13 23:30:38.641288032 +0100
@@ -103,8 +103,8 @@
endif()
if(MBEDTLS_FOUND)
- get_filename_component(mbedtls_library_path "${MBEDTLS_LIBRARIES}" PATH)
- set(LIBS_PRIVATE "${LIBS_PRIVATE} -L${mbedlts_library_path}")
+ get_filename_component(mbedtls_library_path "${MBEDTLS_LIBRARY}" PATH)
+ set(LIBS_PRIVATE "${LIBS_PRIVATE} -L${mbedtls_library_path}")
endif()
if(POLARSSL_FOUND)
get_filename_component(polarssl_library_path "${POLARSSL_LIBRARIES}" PATH)