package/xxhash: bump to version 0.8.1

- Drop first patch (already in version)
- Refresh upstream status of latest patch
- Update hash of LICENSE and add cli/COPYING:
  85e1ea2ab0

https://github.com/Cyan4973/xxHash/releases/tag/v0.8.1

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Fabrice Fontaine 2022-01-01 23:14:25 +01:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 5f6f3b99fb
commit 5dbdb2535c
5 changed files with 8 additions and 40 deletions

View file

@ -1,31 +0,0 @@
From e345ccaf4daa8c35698ab02c0de346fcc0ca9ef6 Mon Sep 17 00:00:00 2001
From: Yann Collet <cyan@fb.com>
Date: Fri, 6 Aug 2021 15:29:32 -0700
Subject: [PATCH] fixed man page installation
[Retrieved from:
https://github.com/Cyan4973/xxHash/commit/e345ccaf4daa8c35698ab02c0de346fcc0ca9ef6]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Makefile | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/Makefile b/Makefile
index b8552a9f..556a32a0 100644
--- a/Makefile
+++ b/Makefile
@@ -498,10 +498,10 @@ endif
$(Q)ln -sf xxhsum $(DESTDIR)$(BINDIR)/xxh64sum
$(Q)ln -sf xxhsum $(DESTDIR)$(BINDIR)/xxh128sum
@echo Installing man pages
- $(Q)$(INSTALL_DATA) xxhsum.1 $(DESTDIR)$(MANDIR)/xxhsum.1
- $(Q)ln -sf xxhsum.1 $(DESTDIR)$(MANDIR)/xxh32sum.1
- $(Q)ln -sf xxhsum.1 $(DESTDIR)$(MANDIR)/xxh64sum.1
- $(Q)ln -sf xxhsum.1 $(DESTDIR)$(MANDIR)/xxh128sum.1
+ $(Q)$(INSTALL_DATA) $(MAN) $(DESTDIR)$(MANDIR)/xxhsum.1
+ $(Q)ln -sf $(MAN) $(DESTDIR)$(MANDIR)/xxh32sum.1
+ $(Q)ln -sf $(MAN) $(DESTDIR)$(MANDIR)/xxh64sum.1
+ $(Q)ln -sf $(MAN) $(DESTDIR)$(MANDIR)/xxh128sum.1
@echo xxhash installation completed
.PHONY: uninstall

View file

@ -10,13 +10,14 @@ This is especially useful on embedded systems where dynamic library is
not always supported by toolchains
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/Cyan4973/xxHash/pull/665]
[Retrieved from:
https://github.com/Cyan4973/xxHash/commit/db9c199e99f7b4d419647b1ef49c547fc2547516]
---
Makefile | 18 +++++++++++++++---
1 file changed, 15 insertions(+), 3 deletions(-)
diff --git a/Makefile b/Makefile
index 8d4fcd2..5fe7297 100644
index 8d4fcd21..5fe72972 100644
--- a/Makefile
+++ b/Makefile
@@ -505,11 +505,14 @@ libxxhash.pc: libxxhash.pc.in
@ -68,6 +69,3 @@ index 8d4fcd2..5fe7297 100644
@echo xxhash installation completed
.PHONY: uninstall
--
2.33.0

View file

@ -1,3 +1,4 @@
# locally computed
sha256 7054c3ebd169c97b64a92d7b994ab63c70dd53a06974f1f630ab782c28db0f4f xxhash-0.8.0.tar.gz
sha256 9da63520e9293d82c4b1613be5c84058cadb82b02f5972179bad13731d589910 LICENSE
sha256 3bb6b7d6f30c591dd65aaaff1c8b7a5b94d81687998ca9400082c739a690436c xxhash-0.8.1.tar.gz
sha256 553d0035773ddd1590045f8fdc3a4c6ead31e36336721aeca8421e88ed1c9f80 LICENSE
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 cli/COPYING

View file

@ -4,10 +4,10 @@
#
################################################################################
XXHASH_VERSION = 0.8.0
XXHASH_VERSION = 0.8.1
XXHASH_SITE = $(call github,Cyan4973,xxHash,v$(XXHASH_VERSION))
XXHASH_LICENSE = BSD-2-Clause (library), GPL-2.0+ (xxhsum)
XXHASH_LICENSE_FILES = LICENSE
XXHASH_LICENSE_FILES = LICENSE cli/COPYING
XXHASH_INSTALL_STAGING = YES
XXHASH_TARGETS = xxhsum