package/tpm2-tools: bump version to 5.2

Depedency on libuuid was removed in:
210b2d639c

Drop 0001-configure-make-build-gnu99.patch as it is in 5.2

Signed-off-by: Erik Larsson <who+buildroot@cnackers.org>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Erik Larsson 2022-01-02 22:25:59 +01:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent 593683b45f
commit 5e39bd0439
4 changed files with 3 additions and 37 deletions

View file

@ -1,30 +0,0 @@
From 521c3cc506b18c5c84d86e1e90d1daee39849b0c Mon Sep 17 00:00:00 2001
From: William Roberts <william.c.roberts@intel.com>
Date: Mon, 8 Feb 2021 11:57:28 -0600
Subject: [PATCH] configure: make build gnu99
Signed-off-by: William Roberts <william.c.roberts@intel.com>
[Retrieved from:
https://github.com/tpm2-software/tpm2-tools/commit/521c3cc506b18c5c84d86e1e90d1daee39849b0c
and updated to set gnu99 instead of c99 as done by
https://github.com/tpm2-software/tpm2-tools/commit/5d0267428e96989afce406d096994ec5091ee107]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
configure.ac | 3 +++
1 file changed, 3 insertions(+)
diff --git a/configure.ac b/configure.ac
index dc15b5595..25039a0d9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -287,6 +287,9 @@ AC_DEFUN([add_c_flag], [
# -D_GNU_SOURCE is required for execvpe() in options.c
add_c_flag([-D_GNU_SOURCE], [AC_MSG_ERROR([Cannot enable -D_GNU_SOURCE])])
+# Enable gnu99 mode, since we use some of these features.
+add_c_flag([-std=gnu99], [AC_MSG_ERROR([Cannot enable -std=gnu99])])
+
# Best attempt compiler options that are on newer versions of GCC that
# we can't widely enforce without killing other peoples builds.
# Works with gcc only. Needs to be disabled on BSD and clang

View file

@ -7,8 +7,6 @@ config BR2_PACKAGE_TPM2_TOOLS
select BR2_PACKAGE_LIBCURL
select BR2_PACKAGE_OPENSSL
select BR2_PACKAGE_TPM2_TSS
select BR2_PACKAGE_UTIL_LINUX
select BR2_PACKAGE_UTIL_LINUX_LIBUUID
help
TPM (Trusted Platform Module) 2.0 CLI tools based on system
API of TPM2-TSS. These tools can be used to manage keys,

View file

@ -1,3 +1,3 @@
# Locally computed:
sha256 e2802d4093a24b2c65b1f913d0f4c68eadde9b8fd8a9b7a3b17a6e50765e8350 tpm2-tools-4.3.2.tar.gz
sha256 c0b402f6a7b3456e8eb2445211e2d41c46c7e769e05fe4d8909ff64119f7a630 tpm2-tools-5.2.tar.gz
sha256 f6995d52c8b8e4d2c3bace7fc9c330a77a90d808166fbad4d7ead7e8ba2fc66c doc/LICENSE

View file

@ -4,15 +4,13 @@
#
################################################################################
TPM2_TOOLS_VERSION = 4.3.2
TPM2_TOOLS_VERSION = 5.2
TPM2_TOOLS_SITE = https://github.com/tpm2-software/tpm2-tools/releases/download/$(TPM2_TOOLS_VERSION)
TPM2_TOOLS_LICENSE = BSD-3-Clause
TPM2_TOOLS_LICENSE_FILES = doc/LICENSE
TPM2_TOOLS_CPE_ID_VENDOR = tpm2-tools_project
TPM2_TOOLS_SELINUX_MODULES = tpm2
TPM2_TOOLS_DEPENDENCIES = libcurl openssl tpm2-tss host-pkgconf util-linux
# We're patching configure.ac
TPM2_TOOLS_AUTORECONF = YES
TPM2_TOOLS_DEPENDENCIES = libcurl openssl tpm2-tss host-pkgconf
# -fstack-protector-all and FORTIFY_SOURCE=2 is used by
# default. Disable that so the BR2_SSP_* / BR2_FORTIFY_SOURCE_* options