gnuradio: bump to version 3.7.13.3

- This bump to 3.7.13.x fixes build with boost 1.67
- Remove patch (not needed as boost unit_test_framework has been
  removed since
  6dda1a1e95)
- Add host-python-mako and host-python-six dependencies
- Add hash for license file

Fixes:
 - http://autobuild.buildroot.net/results/ca3b01a13cb0c580266aae5f3673b2c0a19ac6a4

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Fabrice Fontaine 2018-06-24 22:12:34 +02:00 committed by Peter Korsgaard
parent bae35c8012
commit 74319f85e6
3 changed files with 9 additions and 44 deletions

View file

@ -1,41 +0,0 @@
By default, the boost test option is mandatory for build environment
detection.
This patch suppress this dependency and allows the test part only if
build_test is enabled at the Buildroot level.
Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
---
Index: gnuradio-3.7.5/volk/cmake/VolkBoost.cmake
===================================================================
--- gnuradio-3.7.5.orig/volk/cmake/Modules/VolkBoost.cmake
+++ gnuradio-3.7.5/volk/cmake/Modules/VolkBoost.cmake
@@ -29,7 +29,6 @@ set(__INCLUDED_VOLK_BOOST_CMAKE TRUE)
set(BOOST_REQUIRED_COMPONENTS
filesystem
system
- unit_test_framework
program_options
)
Index: gnuradio-3.7.5/volk/lib/CMakeLists.txt
===================================================================
--- gnuradio-3.7.5.orig/volk/lib/CMakeLists.txt
+++ gnuradio-3.7.5/volk/lib/CMakeLists.txt
@@ -580,7 +580,10 @@
########################################################################
# Build the QA test application
########################################################################
-if(ENABLE_TESTING)
+
+find_package(Boost "1.35" COMPONENTS "unit_test_framework")
+
+if(ENABLE_TESTING AND BUILD_TEST)
#include Boost headers
include_directories(${Boost_INCLUDE_DIRS})
@@ -597,4 +600,4 @@
TARGET_DEPS volk
)
-endif(ENABLE_TESTING)
+endif(ENABLE_TESTING AND BUILD_TEST)

View file

@ -1,2 +1,5 @@
# From http://gnuradio.org/releases/gnuradio/sha256sums
sha256 87d9ba3183858efdbb237add3f9de40f7d65f25e16904a9bc8d764a7287252d4 gnuradio-3.7.11.tar.gz
sha256 1e07ce40fa3c3eede1fb54e320dad8a221a3c01de341e9cef2d7b265ed06a6e9 gnuradio-3.7.13.3.tar.gz
# Hash for license file:
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING

View file

@ -4,16 +4,19 @@
#
################################################################################
GNURADIO_VERSION = 3.7.11
GNURADIO_VERSION = 3.7.13.3
GNURADIO_SITE = http://gnuradio.org/releases/gnuradio
GNURADIO_LICENSE = GPL-3.0+
GNURADIO_LICENSE_FILES = COPYING
GNURADIO_SUPPORTS_IN_SOURCE_BUILD = NO
# host-python-cheetah is needed for volk to compile
# host-python-cheetah, host-python-mako and host-python-six are needed for volk
# to compile
GNURADIO_DEPENDENCIES = \
host-python-cheetah \
host-python-mako \
host-python-six \
host-swig \
boost