package/supertux: bump to version 0.6.3

Remove upstream patch 0001-CMakeLists.txt-compile-squirrel-with-fPIC.patch

Add new glm dependency added by:

7187e3f6d7

Add new zlib dependency added by:

100bc052bc

Update data/AUTHORS hash since several new assets has been added since
version 0.6.2:

ec5e2f5213
1ff490d322
14ac958c71
392320b790
2fd5ed445c
e45b5f7f86

See:
https://www.supertux.org/news/2021/12/23/0.6.3

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Romain Naour 2021-12-30 14:56:15 +01:00 committed by Thomas Petazzoni
parent cea2b082eb
commit 7ad423ab51
4 changed files with 7 additions and 40 deletions

View file

@ -1,35 +0,0 @@
From 23d0bb0ef0fde52d1cffe235edead09287326fb4 Mon Sep 17 00:00:00 2001
From: Romain Naour <romain.naour@gmail.com>
Date: Sun, 4 Oct 2020 01:11:30 +0200
Subject: [PATCH] CMakeLists.txt: compile squirrel with -fPIC
Ensure that squirrel is compiled with -fPIC to allow linking the static
libraries with dynamically linked programs. This is not a requirement
for most architectures but is mandatory for ARM.
Fixes:
x86_64-buildroot-linux-musl/bin/ld: CMakeFiles/sq_static.dir/sq.c.o: relocation R_X86_64_32 against `.rodata.str1.8' can not be used when making a PIE object; recompile with -fPIC
x86_64-buildroot-linux-musl/bin/ld: final link failed: nonrepresentable section on output
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
CMakeLists.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b1dafa1e..07c603cce 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -412,7 +412,8 @@ ExternalProject_Add(squirrel
-DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
-DCMAKE_CXX_FLAGS=${CMAKE_CXX_FLAGS}
-DCMAKE_INSTALL_PREFIX=${SQUIRREL_PREFIX}
- -DINSTALL_INC_DIR=include)
+ -DINSTALL_INC_DIR=include
+ -DCMAKE_POSITION_INDEPENDENT_CODE=ON)
if(WIN32)
add_library(squirrel_lib SHARED IMPORTED)
--
2.25.4

View file

@ -16,6 +16,7 @@ config BR2_PACKAGE_SUPERTUX
select BR2_PACKAGE_BOOST_LOCALE
select BR2_PACKAGE_BOOST_SYSTEM
select BR2_PACKAGE_FREETYPE
select BR2_PACKAGE_GLM
select BR2_PACKAGE_LIBCURL
select BR2_PACKAGE_LIBGLEW
select BR2_PACKAGE_LIBOGG
@ -26,6 +27,7 @@ config BR2_PACKAGE_SUPERTUX
select BR2_PACKAGE_SDL2
select BR2_PACKAGE_SDL2_IMAGE
select BR2_PACKAGE_SDL2_OPENGL
select BR2_PACKAGE_ZLIB
help
SuperTux is a free classic 2D jump'n run sidescroller game in
a style similar to the original Super Mario games covered

View file

@ -1,4 +1,4 @@
# Locally calculated
sha256 26a9e56ea2d284148849f3239177d777dda5b675a10ab2d76ee65854c91ff598 SuperTux-v0.6.2-Source.tar.gz
sha256 f7940e6009c40226eb34ebab8ffb0e3a894892d891a07b35d0e5762dd41c79f6 SuperTux-v0.6.3-Source.tar.gz
sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 LICENSE.txt
sha256 09645215102c1013a1ef8c16a30bacdb9a78924ca064372290405fabd3e7074d data/AUTHORS
sha256 a000d91146a61b44bdb79c3d2737e82d488b6cd65a23e0415e56915233def0a0 data/AUTHORS

View file

@ -4,7 +4,7 @@
#
################################################################################
SUPERTUX_VERSION = 0.6.2
SUPERTUX_VERSION = 0.6.3
SUPERTUX_SITE = https://github.com/SuperTux/supertux/releases/download/v$(SUPERTUX_VERSION)
SUPERTUX_SOURCE = SuperTux-v$(SUPERTUX_VERSION)-Source.tar.gz
@ -15,8 +15,8 @@ SUPERTUX_LICENSE_FILES = LICENSE.txt data/AUTHORS
# Use bundled squirrel, tinygettext sexp-cpp packages which are hardcoded in
# the CMake build system.
SUPERTUX_DEPENDENCIES = host-pkgconf boost freetype libcurl libgl libglew \
libogg libpng libvorbis openal physfs sdl2 sdl2_image
SUPERTUX_DEPENDENCIES = host-pkgconf boost freetype glm libcurl libgl libglew \
libogg libpng libvorbis openal physfs sdl2 sdl2_image zlib
# CMAKE_BUILD_TYPE=Release: disable profiling code (-pg)
# ENABLE_BOOST_STATIC_LIBS=OFF: use boost shared libraries since supertux