package/owl-linux: use kernel-module helper

The owl-linux' Makefile is only calling the Linux buildsystem, so switch
do using the new kernel-module infra.

Get rid of first patch, no longer needed; rename remaining patch.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Yann E. MORIN 2015-07-12 02:21:39 +02:00 committed by Thomas Petazzoni
parent 731c71d23f
commit 7b5c2e658f
3 changed files with 1 additions and 26 deletions

View file

@ -1,16 +0,0 @@
Fix the owl-linux Makefile so that it protects spaces in the CROSS_COMPILE
variable. For example, this variable will contain spaces if ccache is used.
Signed-off-by: Simon Dawson <spdawson@gmail.com>
diff -Nurp a/Makefile b/Makefile
--- a/Makefile 2012-06-14 10:51:45.000000000 +0100
+++ b/Makefile 2012-07-20 10:46:41.636752148 +0100
@@ -35,7 +35,7 @@ else
PWD := $(shell pwd)
default:
- $(MAKE) -C $(KERNELDIR) ARCH=$(ARCH) CROSS_COMPILE=$(CROSS_COMPILE) M=$(PWD) MODE=$(MODE) modules
+ $(MAKE) -C $(KERNELDIR) ARCH=$(ARCH) CROSS_COMPILE="$(CROSS_COMPILE)" M=$(PWD) MODE=$(MODE) modules
clean:
-rm -f *.o *.mod.c *.ko modules.order Module.symvers

View file

@ -10,14 +10,5 @@ OWL_LINUX_LICENSE = PROPRIETARY
OWL_LINUX_LICENSE_FILES = LICENSE
OWL_LINUX_REDISTRIBUTE = NO
OWL_LINUX_DEPENDENCIES = linux
define OWL_LINUX_BUILD_CMDS
$(MAKE) -C $(@D) $(LINUX_MAKE_FLAGS) KERNELDIR=$(LINUX_DIR)
endef
define OWL_LINUX_INSTALL_TARGET_CMDS
$(MAKE) -C $(LINUX_DIR) $(LINUX_MAKE_FLAGS) M="$(@D)" modules_install
endef
$(eval $(kernel-module))
$(eval $(generic-package))