package/libusb-compat: bump to 0.1.8

Removing upstreamed patch and force autoreconf

Signed-off-by: Zoltan Gyarmati <zgyarmati@zgyarmati.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
MyCruft^2
Zoltan Gyarmati 2023-08-12 23:54:46 +02:00 committed by Thomas Petazzoni
parent 07c48f5cba
commit 8ed8f00319
4 changed files with 5 additions and 35 deletions

View File

@ -805,7 +805,6 @@ package/libuio/0001-configure.ac-set-automake-strictness-to-foreign.patch Upstre
package/liburcu/0001-Only-blacklist-ARM-gcc-4.8.0-and-4.8.1.patch Upstream
package/liburcu/0002-fix-don-t-use-C-thread_local-on-MacOs.patch Upstream
package/liburcu/0003-Always-use-__thread-for-Thread-local-storage-except-on-MSVC.patch Upstream
package/libusb-compat/0001-fix-a-build-issue-on-linux.patch Upstream
package/libusbgx/0001-Add-include-of-sys-sysmacro.h.patch Upstream
package/libuwsc/0001-CMakeLists.txt-add-BUILD_EXAMPLE.patch Upstream
package/libuwsc/0002-fix-bad-indentation.patch Upstream

View File

@ -1,32 +0,0 @@
From af07587e8775c25450cda8ba9e9a8b1a58072634 Mon Sep 17 00:00:00 2001
From: Bartosz Golaszewski <brgl@bgdev.pl>
Date: Mon, 3 Jul 2017 15:55:00 +0200
Subject: [PATCH] fix a build issue on linux
On linux PATH_MAX is defined in linux/limits.h. If we include usb.h
without previously having indirectly included it, the build fails.
Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
---
libusb/usb.h | 5 +++++
1 file changed, 5 insertions(+)
diff --git a/libusb/usb.h b/libusb/usb.h
index d2c30aa..7ad9a66 100644
--- a/libusb/usb.h
+++ b/libusb/usb.h
@@ -41,6 +41,11 @@ typedef unsigned __int32 uint32_t;
#include <stdint.h>
#endif
+/* On linux PATH_MAX is defined in linux/limits.h. */
+#if defined(__linux__)
+#include <linux/limits.h>
+#endif
+
/*
* USB spec information
*
--
2.9.3

View File

@ -1,3 +1,3 @@
# Locally computed:
sha256 8259f8d5b084fe43c47823a939e955e0ba21942b8d112266c39d228cc14764d6 libusb-compat-0.1.7.tar.bz2
sha256 698c76484f3dec1e0175067cbd1556c3021e94e7f2313ae3ea6a66d900e00827 libusb-compat-0.1.8.tar.bz2
sha256 5df07007198989c622f5d41de8d703e7bef3d0e79d62e24332ee739a452af62a COPYING

View File

@ -5,7 +5,7 @@
################################################################################
LIBUSB_COMPAT_VERSION_MAJOR = 0.1
LIBUSB_COMPAT_VERSION = $(LIBUSB_COMPAT_VERSION_MAJOR).7
LIBUSB_COMPAT_VERSION = $(LIBUSB_COMPAT_VERSION_MAJOR).8
LIBUSB_COMPAT_SOURCE = libusb-compat-$(LIBUSB_COMPAT_VERSION).tar.bz2
LIBUSB_COMPAT_SITE = https://github.com/libusb/libusb-compat-0.1/releases/download/v$(LIBUSB_COMPAT_VERSION)
LIBUSB_COMPAT_DEPENDENCIES = host-pkgconf libusb
@ -14,6 +14,9 @@ LIBUSB_COMPAT_INSTALL_STAGING = YES
LIBUSB_COMPAT_CONFIG_SCRIPTS = libusb-config
LIBUSB_COMPAT_LICENSE = LGPL-2.1+
LIBUSB_COMPAT_LICENSE_FILES = COPYING
# 0.1.8 tarball was released without configure script by upstream
# discussed here: https://github.com/libusb/libusb-compat-0.1/issues/28
LIBUSB_COMPAT_AUTORECONF = YES
ifeq ($(BR2_STATIC_LIBS),)
LIBUSB_COMPAT_CONF_ENV += \