dt: new package

Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
[Thomas: use <pkg>_STRIP_COMPONENTS = 2, which allows to get rid of
the <pkg>_SUBDIR usage, and make things a bit simpler.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Gustavo Zacarias 2016-01-27 08:40:38 -03:00 committed by Thomas Petazzoni
parent c71d31a84c
commit 938946a476
5 changed files with 85 additions and 0 deletions

View file

@ -73,6 +73,7 @@ menu "Debugging, profiling and benchmark"
source "package/dmalloc/Config.in"
source "package/dropwatch/Config.in"
source "package/dstat/Config.in"
source "package/dt/Config.in"
source "package/duma/Config.in"
source "package/fio/Config.in"
source "package/gdb/Config.in"

View file

@ -0,0 +1,19 @@
Don't force build-dir-in-build-dir logic, symlink the os-specific SCSI
support file in place.
Status: not suitable for upstream.
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
diff -Nura Makefile.linux Makefile.linux
--- a/Makefile.linux 2016-01-26 09:10:03.939963780 -0300
+++ b/Makefile.linux 2016-01-26 09:10:27.140763863 -0300
@@ -129,7 +129,7 @@
echo "Please specify OS={aix,linux,hpux,solaris,windows}"; \
exit 1; \
fi; \
- ln -sf ../scsilib-$(OS).c scsilib.c
+ ln -sf scsilib-$(OS).c scsilib.c
print:;
@$(PRINTER) $(PRINTFLAGS) $(ALL_CFILES)

21
package/dt/Config.in Normal file
View file

@ -0,0 +1,21 @@
comment "dt needs a (e)glibc or uclibc toolchain w/ threads"
depends on BR2_USE_MMU
depends on !BR2_TOOLCHAIN_HAS_THREADS || BR2_TOOLCHAIN_USES_MUSL
config BR2_PACKAGE_DT
bool "dt"
depends on BR2_USE_MMU # fork()
depends on BR2_TOOLCHAIN_HAS_THREADS
# Build fails because of several BSDisms
depends on !BR2_TOOLCHAIN_USES_MUSL
help
dt is a generic data test program used to verify proper
operation of peripherals, file systems, device drivers,
or any data stream supported by the operating system.
In its' simplest mode of operation, dt writes and then
verifys its' default data pattern, then displays
performance statisics and other test parameters
before exiting. Since verification of data is performed,
dt can be thought of as a generic diagnostic tool.
http://www.scsifaq.org/RMiller_Tools/dt.html

5
package/dt/dt.hash Normal file
View file

@ -0,0 +1,5 @@
# From http://pkgs.fedoraproject.org/repo/pkgs/dt/dt-source-v18.32.tar.gz
# (directory name is md5 hash)
md5 3054aeaaba047a1dbe90c2132a382ee2 dt-source-v18.32.tar.gz
# Calculated based on the hash above
sha256 10d164676e918a4d07f233bcd11e4cb6bfd1052c996182cd1827ccd0c063fcc6 dt-source-v18.32.tar.gz

39
package/dt/dt.mk Normal file
View file

@ -0,0 +1,39 @@
################################################################################
#
# dt
#
################################################################################
DT_VERSION = v18.32
DT_SITE = http://pkgs.fedoraproject.org/repo/pkgs/dt/$(DT_SOURCE)/3054aeaaba047a1dbe90c2132a382ee2
DT_SOURCE = dt-source-$(DT_VERSION).tar.gz
DT_STRIP_COMPONENTS = 2
DT_LICENSE = ISC-like
DT_LICENSE_FILES = LICENSE
DT_CFLAGS = \
-std=c99 \
-DMMAP \
-D__linux__ \
-D_GNU_SOURCE \
-D_FILE_OFFSET_BITS=64 \
-DTHREADS \
-DSCSI
# uClibc doesn't provide POSIX AIO
ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),)
DT_CFLAGS += -DAIO
endif
define DT_BUILD_CMDS
$(TARGET_MAKE_ENV) $(MAKE) -C $(@D) -f Makefile.linux \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS) $(DT_CFLAGS)" \
OS=linux
endef
define DT_INSTALL_TARGET_CMDS
$(INSTALL) -D -m 0755 $(@D)/dt $(TARGET_DIR)/usr/bin/dt
endef
$(eval $(generic-package))