dmidecode: new package

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Thomas Petazzoni 2012-06-02 06:13:57 +00:00 committed by Peter Korsgaard
parent 83f43bab37
commit 9d3547529b
4 changed files with 63 additions and 0 deletions

View file

@ -174,6 +174,7 @@ source "package/dbus-python/Config.in"
if BR2_PACKAGE_BUSYBOX_SHOW_OTHERS
source "package/devmem2/Config.in"
endif
source "package/dmidecode/Config.in"
source "package/dmraid/Config.in"
source "package/dosfstools/Config.in"
source "package/e2fsprogs/Config.in"

View file

@ -0,0 +1,9 @@
config BR2_PACKAGE_DMIDECODE
bool "dmidecode"
depends on BR2_i386 || BR2_x86_64
help
Dmidecode reports information about your system's hardware
as described in your system BIOS according to the SMBIOS/DMI
standard.
http://www.nongnu.org/dmidecode/

View file

@ -0,0 +1,35 @@
Minor build system fixes
Usual build system fixes to allow CC/CFLAGS/LDFLAGS to be overriden
from the command line, and completed by additional flags from the
Makefile.
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Index: b/Makefile
===================================================================
--- a/Makefile
+++ b/Makefile
@@ -12,9 +12,10 @@
# (at your option) any later version.
#
-CC = gcc
-CFLAGS = -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
- -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
+CC ?= gcc
+override CFLAGS += \
+ -W -Wall -Wshadow -Wstrict-prototypes -Wpointer-arith -Wcast-qual \
+ -Wcast-align -Wwrite-strings -Wmissing-prototypes -Winline -Wundef
#CFLAGS += -DBIGENDIAN
#CFLAGS += -DALIGNMENT_WORKAROUND
@@ -23,7 +24,7 @@
#CFLAGS += -g
# Pass linker flags here
-LDFLAGS =
+override LDFLAGS +=
DESTDIR =
prefix = /usr/local

View file

@ -0,0 +1,18 @@
#############################################################
#
# dmidecode
#
#############################################################
DMIDECODE_VERSION = 2.11
DMIDECODE_SITE = http://download.savannah.gnu.org/releases/dmidecode/
define DMIDECODE_BUILD_CMDS
$(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
endef
define DMIDECODE_INSTALL_TARGET_CMDS
$(MAKE) -C $(@D) prefix=/usr DESTDIR=$(TARGET_DIR) install
endef
$(eval $(call GENTARGETS))