* Added popt

This commit is contained in:
Nigel Kukard 2008-04-12 09:51:21 +00:00
parent d114386c45
commit 9fadf8ade5
4 changed files with 40 additions and 0 deletions

View file

@ -93,6 +93,7 @@ source "package/module-init-tools/Config.in"
source "package/modutils/Config.in"
endif
source "package/ng-spice-rework/Config.in"
source "package/popt/Config.in"
source "package/portage/Config.in"
if !BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
source "package/procps/Config.in"

7
package/popt/Config.in Normal file
View file

@ -0,0 +1,7 @@
config BR2_PACKAGE_POPT
bool "popt"
default n
help
Popt is a C library for parsing command line parameters.
http://rpm5.org

View file

@ -0,0 +1,12 @@
diff -ru popt-1.14_vanilla/popthelp.c popt-1.14_no-wchar/popthelp.c
--- popt-1.14_vanilla/popthelp.c 2008-03-27 17:33:08.000000000 +0000
+++ popt-1.14_no-wchar/popthelp.c 2008-04-10 05:44:43.000000000 +0000
@@ -15,7 +15,7 @@
#include <sys/ioctl.h>
#endif
-#define POPT_WCHAR_HACK
+/* #define POPT_WCHAR_HACK */
#ifdef POPT_WCHAR_HACK
#include <wchar.h> /* for mbsrtowcs */
/*@access mbstate_t @*/

20
package/popt/popt.mk Normal file
View file

@ -0,0 +1,20 @@
#############################################################
#
# popt
#
#############################################################
POPT_VERSION = 1.14
POPT_SITE = http://rpm5.org/files/popt
POPT_INSTALL_STAGING = YES
POPT_CONF_ENV = ac_cv_va_copy=yes
POPT_CONF_OPT = --target=$(GNU_TARGET_NAME) --host=$(REAL_GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) --prefix=/usr
POPT_INSTALL_TARGET_OPT=DESTDIR=$(TARGET_DIR) install
$(eval $(call AUTOTARGETS,package,popt))