lua: bump to version 5.3.4

[Peter: drop MESSAGE call]
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Francois Perrad 2017-01-30 12:03:27 +01:00 committed by Peter Korsgaard
parent 3e74c1312d
commit a92c6806b5
7 changed files with 6 additions and 37 deletions

View file

@ -1,31 +0,0 @@
Expression list with four or more expressions in a 'for' loop can crash the interpreter.
Fetch from: https://www.lua.org/bugs.html#5.3.3-1
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
--- a/src/lparser.c
+++ b/src/lparser.c
@@ -323,6 +323,8 @@
luaK_nil(fs, reg, extra);
}
}
+ if (nexps > nvars)
+ ls->fs->freereg -= nexps - nvars; /* remove extra values */
}
@@ -1160,11 +1162,8 @@
int nexps;
checknext(ls, '=');
nexps = explist(ls, &e);
- if (nexps != nvars) {
+ if (nexps != nvars)
adjust_assign(ls, nvars, nexps, &e);
- if (nexps > nvars)
- ls->fs->freereg -= nexps - nvars; /* remove extra values */
- }
else {
luaK_setoneret(ls->fs, &e); /* close last expression */
luaK_storevar(ls->fs, &lh->v, &e);
--

View file

@ -6,7 +6,7 @@ Index: b/src/luaconf.h
===================================================================
--- a/src/luaconf.h
+++ b/src/luaconf.h
@@ -188,7 +188,7 @@
@@ -200,7 +200,7 @@
#else /* }{ */

View file

@ -14,7 +14,7 @@ Index: b/etc/lua.pc
+# grep '^V=' ../Makefile
+V= 5.3
+# grep '^R=' ../Makefile
+R= 5.3.3
+R= 5.3.4
+
+# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
+prefix= /usr

View file

@ -8,7 +8,7 @@ Index: b/src/lua.c
===================================================================
--- a/src/lua.c
+++ b/src/lua.c
@@ -83,6 +83,13 @@
@@ -85,6 +85,13 @@
#define lua_saveline(L,line) ((void)L, add_history(line))
#define lua_freeline(L,b) ((void)L, free(b))

View file

@ -1,6 +1,6 @@
# Hashes from: http://www.lua.org/ftp/
md5 703f75caa4fdf4a911c1a72e67a27498 lua-5.3.3.tar.gz
sha1 a0341bc3d1415b814cc738b2ec01ae56045d64ef lua-5.3.3.tar.gz
md5 53a9c68bcc0eda58bdc2095ad5cdfc63 lua-5.3.4.tar.gz
sha1 79790cfd40e09ba796b01a571d4d63b52b1cd950 lua-5.3.4.tar.gz
md5 913fdb32207046b273fdb17aad70be13 lua-5.2.4.tar.gz
sha1 ef15259421197e3d85b7d6e4871b8c26fd82c1cf lua-5.2.4.tar.gz

View file

@ -5,7 +5,7 @@
################################################################################
ifeq ($(BR2_PACKAGE_LUA_5_3),y)
LUA_VERSION = 5.3.3
LUA_VERSION = 5.3.4
else
ifeq ($(BR2_PACKAGE_LUA_5_2),y)
LUA_VERSION = 5.2.4