update to latest upstream cvs and add support for nios2

This commit is contained in:
Mike Frysinger 2006-01-04 04:05:05 +00:00
parent 85eff8d0e4
commit b36f67cc85
13 changed files with 184 additions and 50 deletions

View file

@ -9,6 +9,6 @@ D/tests////
D/testsuite////
/Makefile/1.6/Thu Aug 4 14:15:16 2005//
/uname/1.4/Thu Aug 4 14:15:16 2005//
/ChangeLog/1.339/Mon Nov 21 19:15:04 2005//
/config.guess/1.336/Result of merge//
/config.sub/1.331/Result of merge//
/ChangeLog/1.346/Wed Jan 4 04:04:46 2006//
/config.guess/1.342/Wed Jan 4 04:04:46 2006//
/config.sub/1.337/Wed Jan 4 04:04:46 2006//

View file

@ -1 +1 @@
:ext:anoncvs@savannah.gnu.org:/cvsroot/config
:pserver:anonymous@cvs.savannah.gnu.org:/cvsroot/config

View file

@ -1,3 +1,58 @@
2006-01-02 Ben Elliston <bje@gnu.org>
* config.guess (*:SolidBSD:*:*): New.
* config.sub (-solidbsd*): New.
* testsuite/config-guess.data: Add test case.
* testsuite/config-sub.data: Ditto.
2005-12-23 Ben Elliston <bje@gnu.org>
From Takahashi Yoshihiro <nyan@jp.FreeBSD.org>:
* config.guess (pc98:FreeBSD:*:*) Add special case.
* config.sub (pc98, pc98-*): New.
* testsuite/config-guess.data: Add test case.
* testsuite/config-sub.data: Ditto.
2005-12-22 Ben Elliston <bje@gnu.org>
From John Williams <jwilliams@itee.uq.edu.au>:
* config.sub (mb, microblaze): New basic_machine.
* testsuite/config-sub.data: New tests.
2005-12-13 Ralf Wildenhues <Ralf.Wildenhues@gmx.de>
* config.guess (mips:Linux:*:*, mips64:Linux:*:*, i*86:Linux:*:*):
Fix quoting of eval command line, allow for preprocessor to insert
white space between C tokens.
(i*86:Linux:*:*): Handle Portland Group pgcc like Intel icc; it
doesn't define __ELF__ either.
2005-12-11 Ben Elliston <bje@gnu.org>
From Shaun Jackman <sjackman@gmail.com>:
* config.sub: Add the KERNEL-OS combination linux-newlib*.
* testsuite/config-sub.data: Add a test for i386-linux-newlib.
2005-12-11 Ben Elliston <bje@gnu.org>
Reported by Leif Ekblad <leif@rdos.net>:
* config.guess (i*86:rdos:*:*): New.
* config.sub: Handle rdos.
* testsuite/config-guess.data: Add test case for RDOS.
* testsuite/config-sub.data: Likewise.
2005-12-09 Ben Elliston <bje@gnu.org>
Reported by Jan-Benedict Glaw <jbglaw@lug-owl.de>:
* config.guess (vax:Linux:*:): Detect as vax-dec-linux-gnu.
* testsuite/config-guess.data: Add test.
2005-12-09 Nathan Sidwell <nathan@codesourcery.com>
* config.sub (mt): Rename from ms1.
(ms1): Alias it to mt for backward compatibility.
* testsuite/config-sub.data: Update testsuite.
2005-11-13 Kean Johnston <jkj@sco.com>
* config.sub: Allow -sco6 and -sco5v6 to be aliases for SCO

View file

@ -3,7 +3,7 @@
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
# 2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
timestamp='2005-11-11'
timestamp='2006-01-02'
# This file is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
@ -223,6 +223,9 @@ case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
*:ekkoBSD:*:*)
echo ${UNAME_MACHINE}-unknown-ekkobsd${UNAME_RELEASE}
exit ;;
*:SolidBSD:*:*)
echo ${UNAME_MACHINE}-unknown-solidbsd${UNAME_RELEASE}
exit ;;
macppc:MirBSD:*:*)
echo powerppc-unknown-mirbsd${UNAME_RELEASE}
exit ;;
@ -781,7 +784,12 @@ EOF
echo ${UNAME_MACHINE}-unknown-bsdi${UNAME_RELEASE}
exit ;;
*:FreeBSD:*:*)
echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'`
case ${UNAME_MACHINE} in
pc98)
echo i386-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
*)
echo ${UNAME_MACHINE}-unknown-freebsd`echo ${UNAME_RELEASE}|sed -e 's/[-(].*//'` ;;
esac
exit ;;
i*:CYGWIN*:*)
echo ${UNAME_MACHINE}-pc-cygwin
@ -868,7 +876,7 @@ EOF
#endif
#endif
EOF
eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
eval "`$CC_FOR_BUILD -E $dummy.c 2>/dev/null | sed -n '/^CPU/{s: ::g;p;}'`"
test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
;;
mips64:Linux:*:*)
@ -887,7 +895,7 @@ EOF
#endif
#endif
EOF
eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
eval "`$CC_FOR_BUILD -E $dummy.c 2>/dev/null | sed -n '/^CPU/{s: ::g;p;}'`"
test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
;;
or32:Linux:*:*)
@ -928,7 +936,7 @@ EOF
echo ${UNAME_MACHINE}-ibm-linux
exit ;;
sh64*:Linux:*:*)
echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
sh*:Linux:*:*)
echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
@ -936,6 +944,9 @@ EOF
sparc:Linux:*:* | sparc64:Linux:*:*)
echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
vax:Linux:*:*)
echo ${UNAME_MACHINE}-dec-linux-${LIBC}
exit ;;
x86_64:Linux:*:*)
echo x86_64-unknown-linux-${LIBC}
exit ;;
@ -966,6 +977,7 @@ EOF
echo "${UNAME_MACHINE}-pc-linux-${LIBC}oldld"
exit ;;
esac
# This should get integrated into the C code below, but now we hack
if [ "$LIBC" != "gnu" ] ; then echo "$TENTATIVE" && exit 0 ; fi
# Determine whether the default compiler is a.out or elf
eval $set_cc_for_build
@ -982,7 +994,7 @@ EOF
LIBC=gnulibc1
# endif
#else
#ifdef __INTEL_COMPILER
#if defined(__INTEL_COMPILER) || defined(__PGI)
LIBC=gnu
#else
LIBC=gnuaout
@ -992,7 +1004,7 @@ EOF
LIBC=dietlibc
#endif
EOF
eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^LIBC=`
eval "`$CC_FOR_BUILD -E $dummy.c 2>/dev/null | sed -n '/^LIBC/{s: ::g;p;}'`"
test x"${LIBC}" != x && {
echo "${UNAME_MACHINE}-pc-linux-${LIBC}"
exit
@ -1281,6 +1293,9 @@ EOF
i*86:skyos:*:*)
echo ${UNAME_MACHINE}-pc-skyos`echo ${UNAME_RELEASE}` | sed -e 's/ .*$//'
exit ;;
i*86:rdos:*:*)
echo ${UNAME_MACHINE}-pc-rdos
exit ;;
esac
#echo '(No uname command or uname output not recognized.)' 1>&2

View file

@ -3,7 +3,7 @@
# Copyright (C) 1992, 1993, 1994, 1995, 1996, 1997, 1998, 1999,
# 2000, 2001, 2002, 2003, 2004, 2005 Free Software Foundation, Inc.
timestamp='2005-11-13'
timestamp='2006-01-02'
# This file is (in principle) common to ALL GNU software.
# The presence of a machine in this file suggests that SOME GNU software
@ -119,8 +119,9 @@ esac
# Here we must recognize all the valid KERNEL-OS combinations.
maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
case $maybe_os in
nto-qnx* | linux-gnu* | linux-dietlibc | linux-uclibc* | uclinux-uclibc* | uclinux-gnu* | \
kfreebsd*-gnu* | knetbsd*-gnu* | netbsd*-gnu* | storm-chaos* | os2-emx* | rtmk-nova*)
nto-qnx* | linux-gnu* | linux-dietlibc | linux-newlib* | linux-uclibc* | \
uclinux-uclibc* | uclinux-gnu* | kfreebsd*-gnu* | knetbsd*-gnu* | netbsd*-gnu* | \
storm-chaos* | os2-emx* | rtmk-nova*)
os=-$maybe_os
basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
;;
@ -247,7 +248,7 @@ case $basic_machine in
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
| i370 | i860 | i960 | ia64 \
| ip2k | iq2000 \
| m32r | m32rle | m68000 | m68k | m88k | maxq | mcore \
| m32r | m32rle | m68000 | m68k | m88k | maxq | mb | microblaze | mcore \
| mips | mipsbe | mipseb | mipsel | mipsle \
| mips16 \
| mips64 | mips64el \
@ -265,7 +266,7 @@ case $basic_machine in
| mipsisa64sr71k | mipsisa64sr71kel \
| mipstx39 | mipstx39el \
| mn10200 | mn10300 \
| ms1 \
| mt \
| msp430 \
| ns16k | ns32k \
| or32 \
@ -294,6 +295,13 @@ case $basic_machine in
;;
m88110 | m680[12346]0 | m683?2 | m68360 | m5200 | v70 | w65 | z8k)
;;
ms1)
basic_machine=mt-unknown
;;
nios2 | nios2-* | nios2 | nios2-*)
basic_machine=nios2-altera
os=-none
;;
# We use `pc' rather than `unknown'
# because (1) that's what they normally are, and
@ -344,7 +352,7 @@ case $basic_machine in
| mipsisa64sr71k-* | mipsisa64sr71kel-* \
| mipstx39-* | mipstx39el-* \
| mmix-* \
| ms1-* \
| mt-* \
| msp430-* \
| none-* | np1-* | ns16k-* | ns32k-* \
| orion-* \
@ -722,6 +730,9 @@ case $basic_machine in
basic_machine=i386-pc
os=-msdos
;;
ms1-*)
basic_machine=`echo $basic_machine | sed -e 's/ms1-/mt-/'`
;;
mvs)
basic_machine=i370-ibm
os=-mvs
@ -829,6 +840,12 @@ case $basic_machine in
pc532 | pc532-*)
basic_machine=ns32k-pc532
;;
pc98)
basic_machine=i386-pc
;;
pc98-*)
basic_machine=i386-`echo $basic_machine | sed 's/^[^-]*-//'`
;;
pentium | p5 | k5 | k6 | nexgen | viac3)
basic_machine=i586-pc
;;
@ -885,6 +902,10 @@ case $basic_machine in
basic_machine=i586-unknown
os=-pw32
;;
rdos)
basic_machine=i386-pc
os=-rdos
;;
rom68k)
basic_machine=m68k-rom68k
os=-coff
@ -1200,21 +1221,23 @@ case $os in
| -aos* \
| -nindy* | -vxsim* | -vxworks* | -ebmon* | -hms* | -mvs* \
| -clix* | -riscos* | -uniplus* | -iris* | -rtu* | -xenix* \
| -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* | -openbsd* \
| -hiux* | -386bsd* | -knetbsd* | -mirbsd* | -netbsd* \
| -openbsd* | -solidbsd* \
| -ekkobsd* | -kfreebsd* | -freebsd* | -riscix* | -lynxos* \
| -bosx* | -nextstep* | -cxux* | -aout* | -elf* | -oabi* \
| -ptx* | -coff* | -ecoff* | -winnt* | -domain* | -vsta* \
| -udi* | -eabi* | -lites* | -ieee* | -go32* | -aux* \
| -chorusos* | -chorusrdb* \
| -cygwin* | -pe* | -psos* | -moss* | -proelf* | -rtems* \
| -mingw32* | -linux-gnu* | -linux-uclibc* | -uxpv* | -beos* | -mpeix* | -udk* \
| -mingw32* | -linux-gnu* | -linux-newlib* | -linux-uclibc* \
| -uxpv* | -beos* | -mpeix* | -udk* \
| -interix* | -uwin* | -mks* | -rhapsody* | -darwin* | -opened* \
| -openstep* | -oskit* | -conix* | -pw32* | -nonstopux* \
| -storm-chaos* | -tops10* | -tenex* | -tops20* | -its* \
| -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
| -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
| -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
| -skyos* | -haiku* | -irx*)
| -skyos* | -haiku* | -rdos* | -irx*)
# Remember, each alternative MUST END IN *, to match a version number.
;;
-qnx*)

View file

@ -1,10 +1,10 @@
Index: config.guess
===================================================================
RCS file: /cvsroot/config/config/config.guess,v
retrieving revision 1.334
diff -u -p -r1.334 config.guess
--- config.guess
+++ config.guess
retrieving revision 1.341
diff -u -p -r1.341 config.guess
--- config.guess 22 Dec 2005 23:50:21 -0000 1.341
+++ config.guess 30 Dec 2005 23:47:21 -0000
@@ -138,6 +138,23 @@ UNAME_RELEASE=`(uname -r) 2>/dev/null` |
UNAME_SYSTEM=`(uname -s) 2>/dev/null` || UNAME_SYSTEM=unknown
UNAME_VERSION=`(uname -v) 2>/dev/null` || UNAME_VERSION=unknown
@ -29,7 +29,7 @@ diff -u -p -r1.334 config.guess
# Note: order is significant - the case branches are not exclusive.
case "${UNAME_MACHINE}:${UNAME_SYSTEM}:${UNAME_RELEASE}:${UNAME_VERSION}" in
@@ -815,25 +832,25 @@ EOF
@@ -820,25 +837,25 @@ EOF
echo ${UNAME_MACHINE}-pc-minix
exit ;;
arm*:Linux:*:*)
@ -62,19 +62,19 @@ diff -u -p -r1.334 config.guess
exit ;;
mips:Linux:*:*)
eval $set_cc_for_build
@@ -852,7 +869,7 @@ EOF
@@ -857,7 +874,7 @@ EOF
#endif
EOF
eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
eval "`$CC_FOR_BUILD -E $dummy.c 2>/dev/null | sed -n '/^CPU/{s: ::g;p;}'`"
- test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
+ test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
;;
mips64:Linux:*:*)
eval $set_cc_for_build
@@ -871,16 +888,16 @@ EOF
@@ -876,16 +893,16 @@ EOF
#endif
EOF
eval `$CC_FOR_BUILD -E $dummy.c 2>/dev/null | grep ^CPU=`
eval "`$CC_FOR_BUILD -E $dummy.c 2>/dev/null | sed -n '/^CPU/{s: ::g;p;}'`"
- test x"${CPU}" != x && { echo "${CPU}-unknown-linux-gnu"; exit; }
+ test x"${CPU}" != x && { echo "${CPU}-unknown-linux-${LIBC}"; exit; }
;;
@ -92,7 +92,7 @@ diff -u -p -r1.334 config.guess
exit ;;
alpha:Linux:*:*)
case `sed -n '/^cpu model/s/^.*: \(.*\)/\1/p' < /proc/cpuinfo` in
@@ -893,34 +910,34 @@ EOF
@@ -898,37 +915,37 @@ EOF
EV68*) UNAME_MACHINE=alphaev68 ;;
esac
objdump --private-headers /bin/sh | grep ld.so.1 >/dev/null
@ -121,7 +121,7 @@ diff -u -p -r1.334 config.guess
exit ;;
sh64*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
sh*:Linux:*:*)
- echo ${UNAME_MACHINE}-unknown-linux-gnu
@ -131,13 +131,17 @@ diff -u -p -r1.334 config.guess
- echo ${UNAME_MACHINE}-unknown-linux-gnu
+ echo ${UNAME_MACHINE}-unknown-linux-${LIBC}
exit ;;
vax:Linux:*:*)
- echo ${UNAME_MACHINE}-dec-linux-gnu
+ echo ${UNAME_MACHINE}-dec-linux-${LIBC}
exit ;;
x86_64:Linux:*:*)
- echo x86_64-unknown-linux-gnu
+ echo x86_64-unknown-linux-${LIBC}
exit ;;
i*86:Linux:*:*)
# The BFD linker knows what the default object file format is, so
@@ -935,20 +952,21 @@ EOF
@@ -943,20 +960,22 @@ EOF
p'`
case "$ld_supported_targets" in
elf32-i386)
@ -159,6 +163,7 @@ diff -u -p -r1.334 config.guess
+ echo "${UNAME_MACHINE}-pc-linux-${LIBC}oldld"
exit ;;
esac
+ # This should get integrated into the C code below, but now we hack
+ if [ "$LIBC" != "gnu" ] ; then echo "$TENTATIVE" && exit 0 ; fi
# Determine whether the default compiler is a.out or elf
eval $set_cc_for_build

View file

@ -0,0 +1,18 @@
Index: config.sub
===================================================================
RCS file: /cvsroot/config/config/config.sub,v
retrieving revision 1.336
diff -u -p -r1.336 config.sub
--- config.sub 22 Dec 2005 23:50:21 -0000 1.336
+++ config.sub 30 Dec 2005 23:37:29 -0000
@@ -298,6 +298,10 @@ case $basic_machine in
ms1)
basic_machine=mt-unknown
;;
+ nios2 | nios2-* | nios2 | nios2-*)
+ basic_machine=nios2-altera
+ os=-none
+ ;;
# We use `pc' rather than `unknown'
# because (1) that's what they normally are, and

View file

@ -1,11 +1,11 @@
Index: config.sub
===================================================================
RCS file: /cvsroot/config/config/config.sub,v
retrieving revision 1.330
diff -u -p -r1.330 config.sub
--- config.sub
+++ config.sub
@@ -234,7 +234,7 @@ case $basic_machine in
retrieving revision 1.336
diff -u -p -r1.336 config.sub
--- config.sub 22 Dec 2005 23:50:21 -0000 1.336
+++ config.sub 30 Dec 2005 23:38:29 -0000
@@ -243,7 +243,7 @@ case $basic_machine in
| arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
| bfin \
| c4x | clipper \
@ -14,7 +14,7 @@ diff -u -p -r1.330 config.sub
| fr30 | frv \
| h8300 | h8500 | hppa | hppa1.[01] | hppa2.0 | hppa2.0[nw] | hppa64 \
| i370 | i860 | i960 | ia64 \
@@ -678,6 +678,24 @@ case $basic_machine in
@@ -690,6 +690,24 @@ case $basic_machine in
basic_machine=m68k-atari
os=-mint
;;
@ -39,12 +39,12 @@ diff -u -p -r1.330 config.sub
mips3*-*)
basic_machine=`echo $basic_machine | sed -e 's/mips3/mips64/'`
;;
@@ -1188,7 +1206,7 @@ case $os in
@@ -1214,7 +1232,7 @@ case $os in
| -os2* | -vos* | -palmos* | -uclinux* | -nucleus* \
| -morphos* | -superux* | -rtmk* | -rtmk-nova* | -windiss* \
| -powermax* | -dnix* | -nx6 | -nx7 | -sei* | -dragonfly* \
- | -skyos* | -haiku*)
+ | -skyos* | -haiku* | -irx*)
- | -skyos* | -haiku* | -rdos*)
+ | -skyos* | -haiku* | -rdos* | -irx*)
# Remember, each alternative MUST END IN *, to match a version number.
;;
-qnx*)

View file

@ -12,9 +12,14 @@ The fact that the sh variant matching is the ugliest out of any of the other
architectures doesn't seem to deter GCC folk from their well thought out and
brilliantly managed config target list.
--- config.sub 2005-11-21 21:18:16.000000000 +0200
+++ config.sub 2005-11-21 21:39:48.000000000 +0200
@@ -264,7 +264,7 @@
Index: config.sub
===================================================================
RCS file: /cvsroot/config/config/config.sub,v
retrieving revision 1.336
diff -u -p -r1.336 config.sub
--- config.sub 22 Dec 2005 23:50:21 -0000 1.336
+++ config.sub 30 Dec 2005 23:36:24 -0000
@@ -273,7 +273,7 @@ case $basic_machine in
| pdp10 | pdp11 | pj | pjl \
| powerpc | powerpc64 | powerpc64le | powerpcle | ppcbe \
| pyramid \

View file

@ -1,7 +1,7 @@
/.cvsignore/1.1/Thu Aug 4 22:41:55 2005//
/config-guess.sh/1.4/Thu Aug 4 14:15:16 2005//
/config-sub.sh/1.2/Thu Aug 4 14:15:16 2005//
/uname.in/1.1/Thu Aug 4 14:15:16 2005//
/.cvsignore/1.1/Thu Aug 4 22:41:55 2005//
/config-guess.data/1.17/Mon Nov 21 19:15:05 2005//
/config-sub.data/1.24/Mon Nov 21 19:15:05 2005//
/config-guess.data/1.21/Wed Jan 4 04:04:46 2006//
/config-sub.data/1.30/Wed Jan 4 04:04:46 2006//
D

View file

@ -1 +1 @@
:ext:anoncvs@savannah.gnu.org:/cvsroot/config
:pserver:anonymous@cvs.savannah.gnu.org:/cvsroot/config

View file

@ -14,3 +14,7 @@ or32 ignored Linux ignored or32-unknown-linux-gnu
x86_64 1.5.18(0.132/4/2) CYGWIN_NT-5.2 ignored x86_64-unknown-cygwin
x86 5.0 Interix ignored i586-pc-interix5
ppc64 2.6.9-22 Linux ignored powerpc64-unknown-linux-gnu
vax 2.6.15 Linux ignored vax-dec-linux-gnu
i586 ignored rdos ignored i586-pc-rdos
pc98 7.0 FreeBSD ignored i386-unknown-freebsd7.0
i586 1.0 SolidBSD ignored i586-unknown-solidbsd1.0

View file

@ -11,6 +11,7 @@ i386-linux i386-pc-linux-gnu
i386-netbsd i386-pc-netbsd
i386-openbsd i386-pc-openbsd
i386-freebsd i386-pc-freebsd
pc98-freebsd i386-pc-freebsd
i386-elf i386-pc-elf
i486-elf i486-pc-elf
i586-elf i586-pc-elf
@ -39,8 +40,8 @@ arm-unknown-riscos arm-unknown-riscos
i586-skyos i586-pc-skyos
m32c m32c-unknown-none
m32c-elf m32c-unknown-elf
ms1 ms1-unknown-none
ms1-elf ms1-unknown-elf
ms1 mt-unknown-none
ms1-elf mt-unknown-elf
mips64vr5900-elf mips64vr5900-unknown-elf
mips64vr5900el-elf mips64vr5900el-unknown-elf
mips64vr5900 mips64vr5900-unknown-elf
@ -72,3 +73,11 @@ sparc-haiku sparc-unknown-haiku
powerpc-haiku powerpc-unknown-haiku
i386-pc-sco6 i386-pc-sco5v6
i386-pc-sco5v6 i386-pc-sco5v6
mt mt-unknown-none
mt-elf mt-unknown-elf
rdos i386-pc-rdos
i586-rdos i586-pc-rdos
i386-linux-newlib i386-pc-linux-newlib
mb-elf mb-unknown-elf
microblaze-elf microblaze-unknown-elf
i386-solidbsd i386-pc-solidbsd