package/softether: fix compilation error due to librt linking

/home/buildroot/instance-0/output/build/host-softether-16b713b98da8dba29f0f845d5a8c36d6f7c34824/src/Mayaqua/Unix.c:2066:
undefined reference to `clock_gettime'

[Thomas: remove commit 7663664113, which
was a different fix for the same problem.]

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Bernd Kuhls 2015-03-10 19:58:36 +01:00 committed by Thomas Petazzoni
parent 7ecd241db1
commit bbed64d46b
2 changed files with 33 additions and 6 deletions

View file

@ -0,0 +1,33 @@
Downloaded from
https://github.com/dajhorn/SoftEtherVPN/commit/9a8538a6f2287fe8bebd0a7185de408e31e5a7df
Fixes
http://autobuild.buildroot.net/results/48f/48f778a891e0bf6a60ed2e4bec057c338ec25ec9/
and many others
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
From 9a8538a6f2287fe8bebd0a7185de408e31e5a7df Mon Sep 17 00:00:00 2001
From: Darik Horn <dajhorn@vanadac.com>
Date: Thu, 5 Jun 2014 21:02:02 -0400
Subject: [PATCH] Add an explicit autoconf check for librt.
The realtime extensions library is not automatically linked on Debian ARM
platforms, so do an AC_CHECK_LIB for it in the configuration macro.
---
configure.ac | 1 +
1 file changed, 1 insertion(+)
diff --git a/configure.ac b/configure.ac
index 165623a..6f85393 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,6 +60,7 @@ CC="$PTHREAD_CC"
CFLAGS="$CFLAGS $PTHREAD_CFLAGS"
LIBS="$PTHREAD_LIBS $LIBS"
+AC_CHECK_LIB([rt],[clock_gettime])
AX_CHECK_OPENSSL([
AC_SUBST(OPENSSL_LIBS)

View file

@ -28,12 +28,6 @@ SOFTETHER_CONF_OPTS = \
--with-openssl="$(STAGING_DIR)/usr" \
--with-zlib="$(STAGING_DIR)/usr"
# softether uses clock_gettime but forgets to link against -lrt
# breaking the build against older libc's that don't provide this
# symbol in libc
SOFTETHER_CONF_ENV += LIBS+=" -lrt"
HOST_SOFTETHER_CONF_ENV += LIBS+=" -lrt"
# host-libiconv does not exist, therefore we need this extra line
HOST_SOFTETHER_DEPENDENCIES = host-pkgconf host-openssl host-readline