package/ttyd: bump to version 1.6.1

Removed patches applied upstream.

Signed-off-by: Tian Yuanhao <tianyuanhao@aliyun.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020.08.x
Tian Yuanhao 2020-07-02 13:30:21 +08:00 committed by Thomas Petazzoni
parent 4e813db533
commit c3b28bfb0e
3 changed files with 2 additions and 43 deletions

View File

@ -1,41 +0,0 @@
From cec921a680576865847d98552ded2a67efd8eb50 Mon Sep 17 00:00:00 2001
From: Bartosz Bilas <b.bilas@grinn-global.com>
Date: Mon, 15 Jun 2020 17:32:26 +0200
Subject: [PATCH] cmake: fix build without C++
Specify that ttyd is a C project to avoid the
following build failure if a C++ compiler isn't found.
CMake Error at CMakeLists.txt:3 (project):
The CMAKE_CXX_COMPILER:
/home/bartekk/Projects/buildroots/buildroot-dev/buildroot/output/host/bin/arm-buildroot-linux-uclibcgnueabihf-g++
is not a full path to an existing compiler tool.
Tell CMake where to find the compiler by setting either the environment
variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
to the compiler, or to the compiler name if it is in the PATH.
Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
---
Upstream status: https://github.com/tsl0922/ttyd/pull/382
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8061f47..efd76d2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 2.8)
-project(ttyd)
+project(ttyd C)
set(PROJECT_VERSION "1.6.0")
find_package(Git)
--
2.27.0

View File

@ -1,3 +1,3 @@
# Locally computed:
sha256 d14740bc82be0d0760dd0a3c97acbcbde490412a4edc61edabe46d311b068f83 ttyd-1.6.0.tar.gz
sha256 d72dcca3dec00cda87b80a0a25ae4fee2f8b9098c1cdb558508dcb14fbb6fafc ttyd-1.6.1.tar.gz
sha256 711762f081c180ade3d09d7b0b7537eaf35eca8d1671e47bc66eaa39376edb12 LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
TTYD_VERSION = 1.6.0
TTYD_VERSION = 1.6.1
TTYD_SITE = $(call github,tsl0922,ttyd,$(TTYD_VERSION))
TTYD_LICENSE = MIT
TTYD_LICENSE_FILES = LICENSE