package/neon-2-sse: bump to version 097a5ecacd527d5b5c3006e360fb9cb1c1c48a1f

Drop patch which is now upstream.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2023.02.x
James Hilliard 2023-01-31 17:02:48 -07:00 committed by Peter Korsgaard
parent 247e2d0eb1
commit c419ef62d8
3 changed files with 2 additions and 42 deletions

View File

@ -1,40 +0,0 @@
From 186ec82e033d8c718d760d14945535a9d7e160fd Mon Sep 17 00:00:00 2001
From: James Hilliard <james.hilliard1@gmail.com>
Date: Sun, 29 Jan 2023 21:00:27 -0700
Subject: [PATCH] Fix cmake languages
When no language is set cmake defaults to C and CXX, since we support
C by itself we should set the project language to C so that we don't
get a compiler error when building without a CXX toolchain.
Fixes:
CMake Error at CMakeLists.txt:5 (project):
No CMAKE_CXX_COMPILER could be found.
Tell CMake where to find the compiler by setting either the environment
variable "CXX" or the CMake cache entry CMAKE_CXX_COMPILER to the full path
to the compiler, or to the compiler name if it is in the PATH.
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[Upstream status:
https://github.com/intel/ARM_NEON_2_x86_SSE/pull/62]
---
CMakeLists.txt | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4b8980..8f58e79 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,7 +2,7 @@
# Modification: Copyright (C) 2017 David Hirvonen
cmake_minimum_required(VERSION 3.0)
-project(NEON_2_SSE VERSION 1.0.0)
+project(NEON_2_SSE VERSION 1.0.0 LANGUAGES C)
add_library(${PROJECT_NAME} INTERFACE)
--
2.34.1

View File

@ -1,4 +1,4 @@
# Locally calculated
sha256 019fbc7ec25860070a1d90e12686fc160cfb33e22aa063c80f52b363f1361e9d neon-2-sse-a15b489e1222b2087007546b4912e21293ea86ff.tar.gz
sha256 4567ca8c8cbc8ce0ea3ddb9dc0f158707eb85c631cb400fd7010cd299cdc5377 neon-2-sse-097a5ecacd527d5b5c3006e360fb9cb1c1c48a1f.tar.gz
# License files, locally calculated
sha256 7022f51b439a5915e933ecc270c83e24ca0cb2cceeb08b0132dcd4dbb03ed2dc LICENSE

View File

@ -4,7 +4,7 @@
#
################################################################################
NEON_2_SSE_VERSION = a15b489e1222b2087007546b4912e21293ea86ff
NEON_2_SSE_VERSION = 097a5ecacd527d5b5c3006e360fb9cb1c1c48a1f
NEON_2_SSE_SITE = $(call github,intel,ARM_NEON_2_x86_SSE,$(NEON_2_SSE_VERSION))
NEON_2_SSE_LICENSE = BSD-2-Clause
NEON_2_SSE_LICENSE_FILES = LICENSE