package/hwloc: bump version to 1.11.7

Added md5 & sha256 hashes, removed patch applied upstream:
f08f4629f9

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2017.08.x
Bernd Kuhls 2017-06-04 15:36:22 +02:00 committed by Thomas Petazzoni
parent 6fdb340d9e
commit c54aa6bf60
3 changed files with 7 additions and 41 deletions

View File

@ -1,35 +0,0 @@
From d5e802c9c2ed8dbe5c937e84bc3ab440218aa8de Mon Sep 17 00:00:00 2001
From: Peter Korsgaard <peter@korsgaard.com>
Date: Tue, 12 May 2015 16:03:14 +0200
Subject: [PATCH] utils/hwloc/Makefile.am: fix install-man race condition
Make install contains a race condition in utils/hwloc, as both
install-exec-hook (through intall-exec) and install-data trigger
install-man:
http://autobuild.buildroot.net/results/414/41403f8ce4751a27dd1bb9c43f5a97895dea3980/build-end.log
The install-exec-hook target doesn't do anything with the manual pages, so
fix the race condition by dropping the dependency.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
---
utils/hwloc/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/utils/hwloc/Makefile.am b/utils/hwloc/Makefile.am
index 7ca8027..8bbee86 100644
--- a/utils/hwloc/Makefile.am
+++ b/utils/hwloc/Makefile.am
@@ -108,7 +108,7 @@ endif HWLOC_HAVE_LINUX
-e 's/#HWLOC_DATE#/@HWLOC_RELEASE_DATE@/g' \
> $@ < $<
-install-exec-hook: install-man
+install-exec-hook:
$(SED) -e 's/HWLOC_top_builddir\/utils\/hwloc/bindir/' -e 's/HWLOC_top_builddir\/utils\/lstopo/bindir/' -e '/HWLOC_top_builddir/d' $(DESTDIR)$(bindir)/hwloc-assembler-remote > $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp && mv -f $(DESTDIR)$(bindir)/hwloc-assembler-remote.tmp $(DESTDIR)$(bindir)/hwloc-assembler-remote
$(SED) -e 's/HWLOC_top_builddir\/utils\/hwloc/bindir/' -e 's/HWLOC_top_builddir\/utils\/lstopo/bindir/' -e '/HWLOC_top_builddir/d' $(DESTDIR)$(bindir)/hwloc-compress-dir > $(DESTDIR)$(bindir)/hwloc-compress-dir.tmp && mv -f $(DESTDIR)$(bindir)/hwloc-compress-dir.tmp $(DESTDIR)$(bindir)/hwloc-compress-dir
chmod +x $(DESTDIR)$(bindir)/hwloc-assembler-remote $(DESTDIR)$(bindir)/hwloc-compress-dir
--
2.1.4

View File

@ -1,2 +1,5 @@
# From http://www.open-mpi.org/software/hwloc/v1.10/
sha1 76291124e4638b2fbd4deb4cc3cd680e153077b5 hwloc-1.10.1.tar.bz2
# From https://www.open-mpi.org/software/hwloc/v1.11/
md5 13d2e4dbce392cda41f1451d386d9a45 hwloc-1.11.7.tar.bz2
sha1 7b78850b8504a93972a3f114a0e75f9b115607d9 hwloc-1.11.7.tar.bz2
# Locally computed
sha256 ab6910e248eed8c85d08b529917a6aae706b32b346e886ba830895e36a809729 hwloc-1.11.7.tar.bz2

View File

@ -4,16 +4,14 @@
#
################################################################################
HWLOC_VERSION_MAJOR = 1.10
HWLOC_VERSION = $(HWLOC_VERSION_MAJOR).1
HWLOC_VERSION_MAJOR = 1.11
HWLOC_VERSION = $(HWLOC_VERSION_MAJOR).7
HWLOC_SOURCE = hwloc-$(HWLOC_VERSION).tar.bz2
HWLOC_SITE = http://www.open-mpi.org/software/hwloc/v$(HWLOC_VERSION_MAJOR)/downloads
HWLOC_LICENSE = BSD-3-Clause
HWLOC_LICENSE_FILES = COPYING
HWLOC_DEPENDENCIES = host-pkgconf
HWLOC_INSTALL_STAGING = YES
# 0001-utils-hwloc-Makefile.am-fix-install-man-race-conditi.patch touches Makefile.am
HWLOC_AUTORECONF = YES
HWLOC_CONF_OPTS = \
--disable-opencl \