package/openipmi: bump to version 2.0.33

Drop patch (already in version) and so also drop autoreconf

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2023.02.x
Fabrice Fontaine 2022-10-30 18:56:32 +01:00 committed by Thomas Petazzoni
parent c5357f650d
commit c674014c17
3 changed files with 4 additions and 59 deletions

View File

@ -1,53 +0,0 @@
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
From: Baruch Siach <baruch@tkos.co.il>
Date: Wed, 22 Jul 2015 07:04:33 +0300
Subject: [PATCH] Avoid searching host library path
The $(libdir) variable points to the location of the directory on the target
system, /usr/lib by default. When cross compiling this directory contains the
host libraries which may be different than target libraries. Don't use
$(libdir) in the library search path.
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Joel Stanley <joel@jms.id.au>
[Fabrice: refresh patch for 2.0.32]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://sourceforge.net/p/openipmi/patches/35]
---
cmdlang/Makefile.am | 3 +--
unix/Makefile.am | 6 ++----
2 files changed, 3 insertions(+), 6 deletions(-)
diff --git a/cmdlang/Makefile.am b/cmdlang/Makefile.am
index 264ee12be79f..0b3843784656 100644
--- a/cmdlang/Makefile.am
+++ b/cmdlang/Makefile.am
@@ -15,7 +15,7 @@ libOpenIPMIcmdlang_la_SOURCES = cmdlang.c cmd_domain.c cmd_entity.c cmd_mc.c \
$(top_builddir)/utils/libOpenIPMIutils.la \
$(top_builddir)/lib/libOpenIPMI.la
libOpenIPMIcmdlang_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \
- -L$(libdir) -no-undefined
+ -no-undefined
bin_PROGRAMS = openipmish
diff --git a/unix/Makefile.am b/unix/Makefile.am
index 5128839dad13..bd0f897ba8d6 100644
--- a/unix/Makefile.am
+++ b/unix/Makefile.am
@@ -10,12 +10,12 @@ lib_LTLIBRARIES = libOpenIPMIposix.la libOpenIPMIpthread.la
libOpenIPMIpthread_la_LIBADD = -lpthread $(GDBM_LIB) \
$(top_builddir)/utils/libOpenIPMIutils.la $(RT_LIB)
libOpenIPMIpthread_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \
- -L$(libdir) -no-undefined
+ -no-undefined
libOpenIPMIposix_la_SOURCES = posix_os_hnd.c selector.c
libOpenIPMIposix_la_LIBADD = $(top_builddir)/utils/libOpenIPMIutils.la \
$(GDBM_LIB) $(RT_LIB)
libOpenIPMIposix_la_LDFLAGS = -rdynamic -version-info $(LD_VERSION) \
- -L$(libdir) -no-undefined
+ -no-undefined
noinst_HEADERS = heap.h

View File

@ -1,8 +1,8 @@
# From http://sourceforge.net/projects/openipmi/files/OpenIPMI%202.0%20Library/
sha1 73d7dce4312b006983b11367e4a43d4ec52cf888 OpenIPMI-2.0.32.tar.gz
md5 532404c9df7d0e8bde975b95b9e6775b OpenIPMI-2.0.32.tar.gz
sha1 4387f227aad92756e296d1c9421e83231d355dbd OpenIPMI-2.0.33.tar.gz
md5 923d2914dbbc3307712f8c58401bab0f OpenIPMI-2.0.33.tar.gz
# Locally computed
sha256 f6d0fd4c0a74b05f80907229d0b270f54ca23294bcc11979f8b8d12766786945 OpenIPMI-2.0.32.tar.gz
sha256 fb53e9ea5e2681cf8af7cda024b1a0044c675f84116ca27ae9616c8b7ad95b49 OpenIPMI-2.0.33.tar.gz
sha256 32b1062f7da84967e7019d01ab805935caa7ab7321a7ced0e30ebe75e5df1670 COPYING
sha256 185323a62589e7ee80f86bf2ea29caad9a09fdda0ea3f1c00db8b778c7edf60e COPYING.BSD
sha256 5bbcbb737e60fe9deba08ecbd00920cfcc3403ba2e534c64fdeea49d6bb87509 COPYING.LIB

View File

@ -4,15 +4,13 @@
#
################################################################################
OPENIPMI_VERSION = 2.0.32
OPENIPMI_VERSION = 2.0.33
OPENIPMI_SITE = https://sourceforge.net/projects/openipmi/files/OpenIPMI%202.0%20Library
OPENIPMI_SOURCE = OpenIPMI-$(OPENIPMI_VERSION).tar.gz
OPENIPMI_LICENSE = LGPL-2.0+, GPL-2.0+, BSD-3-Clause
OPENIPMI_LICENSE_FILES = COPYING.LIB COPYING COPYING.BSD
OPENIPMI_DEPENDENCIES = popt ncurses readline host-pkgconf
OPENIPMI_INSTALL_STAGING = YES
# Patching Makefile.am
OPENIPMI_AUTORECONF = YES
OPENIPMI_CONF_ENV = ac_cv_path_pkgprog="$(PKG_CONFIG_HOST_BINARY)"
OPENIPMI_CONF_OPTS = \
--with-glib=no \