lft: bump to version 3.76

Drop upstream patches, and disable strip via the STRIP make environment
variable.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Gustavo Zacarias 2016-06-22 20:13:32 -03:00 committed by Peter Korsgaard
parent d472a622be
commit cb91add36b
4 changed files with 3 additions and 48 deletions

View file

@ -1,19 +0,0 @@
Don't forcibly strip binaries, we do so on our own.
Also using strip rather than $(STRIP) is bad when cross-compiling.
Patch status: notified upstream.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura lft-3.74.orig/Makefile.in lft-3.74/Makefile.in
--- lft-3.74.orig/Makefile.in 2016-05-03 14:11:30.965530923 -0300
+++ lft-3.74/Makefile.in 2016-05-03 14:11:42.120918849 -0300
@@ -50,8 +50,6 @@
install: lft lft.8 whob whob.8
@echo "LFT and WhoB"
- @echo " \_Stripping binaries"
- @strip lft whob
@echo " \_Copying files to their intended destinations"
@test -d $(DESTDIR)$(bindir)/. || $(MKDIR) $(DESTDIR)$(bindir)
$(INSTALL) lft $(DESTDIR)$(bindir)/lft

View file

@ -1,27 +0,0 @@
Don't pollute incdir with absolute directories, it's bad when
cross-compiling.
Patch configure directly since autoreconf isn't clean.
Patch status: notified upstream.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura lft-3.74.orig/configure lft-3.74/configure
--- lft-3.74.orig/configure 2016-05-03 14:11:30.964530888 -0300
+++ lft-3.74/configure 2016-05-03 14:12:45.038106775 -0300
@@ -5732,15 +5732,6 @@
-for incdir in /usr/local/include /usr/include
-do
- if test -d $incdir/pcap
- then
- CFLAGS="$CFLAGS -I$incdir/pcap"
- CPPFLAGS="$CFLAGS -I$incdir/pcap"
- fi
-done
-
cat >conftest.$ac_ext <<_ACEOF
/* confdefs.h. */
_ACEOF

View file

@ -1,2 +1,2 @@
# Locally calculated, matches download from fossies.org and pwhois.org
sha256 d7f142b9198162a48dd41261f5982e5189b951e7746e171d6b2c5b9581f26000 lft-3.74.tar.gz
sha256 fa163f8eaa9c27e12ecf533e79d8606895a301d2a75b9a77f0df29ef9a20c561 lft-3.76.tar.gz

View file

@ -4,12 +4,13 @@
#
################################################################################
LFT_VERSION = 3.74
LFT_VERSION = 3.76
LFT_SITE = http://pwhois.org/get
LFT_DEPENDENCIES = libpcap
LFT_LICENSE = VOSTROM Public License for Open Source
LFT_LICENSE_FILES = COPYING
LFT_CONF_OPTS = --with-pcap=$(STAGING_DIR)/usr
LFT_MAKE_ENV = STRIP=true
ifeq ($(BR2_STATIC_LIBS),y)
LFT_CONF_OPTS += LIBS="`$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`"