package/procps-ng: bump to version 3.3.17

- Update indentation in hash file (two spaces)
- Disable w on musl to avoid a build failure:
  https://gitlab.com/procps-ng/procps/-/issues/193

https://gitlab.com/procps-ng/procps/-/blob/v3.3.17/NEWS

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Fabrice Fontaine 2021-12-27 13:47:20 +01:00 committed by Thomas Petazzoni
parent b032faa401
commit cc28c7aa6d
4 changed files with 143 additions and 7 deletions

View file

@ -0,0 +1,93 @@
From 1524a625e693b956ce0b5091c9f89f24fb7e8614 Mon Sep 17 00:00:00 2001
From: "Issam E. Maghni" <issam.e.maghni@mailbox.org>
Date: Fri, 23 Apr 2021 15:58:36 -0400
Subject: [PATCH] configure: Add --disable-w
[Retrieved (and backported) from:
https://gitlab.com/procps-ng/procps/-/commit/1524a625e693b956ce0b5091c9f89f24fb7e8614]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
Makefile.am | 21 +++++++++++++++------
configure.ac | 6 ++++++
2 files changed, 21 insertions(+), 6 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index de15e137..d2356872 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,8 +47,7 @@ bin_PROGRAMS = \
pwdx \
tload \
uptime \
- vmstat \
- w
+ vmstat
if BUILD_PWAIT
bin_PROGRAMS += pwait
endif
@@ -60,8 +59,7 @@ usrbin_exec_PROGRAMS += \
pkill \
pmap \
uptime \
- vmstat \
- w
+ vmstat
endif
lib_LTLIBRARIES = \
@@ -74,7 +72,6 @@ dist_man_MANS = \
pmap.1 \
uptime.1 \
vmstat.8 \
- w.1 \
ps/procps.1
if !CYGWIN
@@ -137,6 +134,19 @@ else
EXTRA_DIST += kill.1
endif
+if BUILD_W
+if CYGWIN
+usrbin_exec_PROGRAMS += w
+else
+bin_PROGRAMS += w
+endif
+
+dist_man_MANS += w.1
+w_SOURCES = w.c lib/fileutils.c
+else
+ EXTRA_DIST += w.1
+endif
+
if WITH_NCURSES
if !CYGWIN
bin_PROGRAMS += \
@@ -213,7 +223,6 @@ endif
tload_SOURCES = tload.c lib/strutils.c lib/fileutils.c
uptime_SOURCES = uptime.c lib/fileutils.c
vmstat_SOURCES = vmstat.c lib/strutils.c lib/fileutils.c
-w_SOURCES = w.c lib/fileutils.c
# proc/libprocps.la
diff --git a/configure.ac b/configure.ac
index 750c0fbb..3e83fb88 100644
--- a/configure.ac
+++ b/configure.ac
@@ -234,6 +234,12 @@ AC_ARG_ENABLE([kill],
[], [enable_kill=yes]
)
AM_CONDITIONAL(BUILD_KILL, test "x$enable_kill" = xyes)
+AC_ARG_ENABLE([w],
+ AS_HELP_STRING([--disable-w], [do not build w]),
+ [], [enable_w=yes]
+)
+AM_CONDITIONAL(BUILD_W, test "x$enable_w" = xyes)
+
AM_CONDITIONAL(LINUX, test "x$host_os" = xlinux-gnu)
AM_CONDITIONAL(CYGWIN, test "x$host_os" = xcygwin)
--
GitLab

View file

@ -0,0 +1,34 @@
From 2763b9880a7aab569694d6ee3170dd7341a26b84 Mon Sep 17 00:00:00 2001
From: "Issam E. Maghni" <issam.e.maghni@mailbox.org>
Date: Fri, 23 Apr 2021 16:53:39 -0400
Subject: [PATCH] escape.c: Fix missing nl_langinfo on certain configs
[Retrieved from:
https://gitlab.com/procps-ng/procps/-/commit/2763b9880a7aab569694d6ee3170dd7341a26b84]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
proc/escape.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/proc/escape.c b/proc/escape.c
index 2e8fb7dd..cf4a80de 100644
--- a/proc/escape.c
+++ b/proc/escape.c
@@ -24,13 +24,13 @@
#include "procps.h"
#include "escape.h"
#include "readproc.h"
+#include "nls.h"
#if (__GNU_LIBRARY__ >= 6) && (!defined(__UCLIBC__) || defined(__UCLIBC_HAS_WCHAR__))
# include <wchar.h>
# include <wctype.h>
# include <stdlib.h> /* MB_CUR_MAX */
# include <ctype.h>
-# include <langinfo.h>
#endif
#define SECURE_ESCAPE_ARGS(dst, bytes, cells) do { \
--
GitLab

View file

@ -1,8 +1,8 @@
# From http://sourceforge.net/projects/procps-ng/files/Production/
md5 2b0717a7cb474b3d6dfdeedfbad2eccc procps-ng-3.3.15.tar.xz
sha1 2929bc64f0cf7b2db997eef79b7187658e47230d procps-ng-3.3.15.tar.xz
md5 d60613e88c2f442ebd462b5a75313d56 procps-ng-3.3.17.tar.xz
sha1 a52952e8bc6aaab812176c00d25adc4d4e1552e2 procps-ng-3.3.17.tar.xz
# Locally calculated after checking signature
# http://downloads.sourceforge.net/project/procps-ng/Production/procps-ng-3.3.15.tar.xz.asc
sha256 10bd744ffcb3de2d591d2f6acf1a54a7ba070fdcc432a855931a5057149f0465 procps-ng-3.3.15.tar.xz
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
sha256 681e386e44a19d7d0674b4320272c90e66b6610b741e7e6305f8219c42e85366 COPYING.LIB
# http://downloads.sourceforge.net/project/procps-ng/Production/procps-ng-3.3.17.tar.xz.asc
sha256 4518b3e7aafd34ec07d0063d250fd474999b20b200218c3ae56f5d2113f141b4 procps-ng-3.3.17.tar.xz
sha256 8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643 COPYING
sha256 681e386e44a19d7d0674b4320272c90e66b6610b741e7e6305f8219c42e85366 COPYING.LIB

View file

@ -4,13 +4,15 @@
#
################################################################################
PROCPS_NG_VERSION = 3.3.15
PROCPS_NG_VERSION = 3.3.17
PROCPS_NG_SOURCE = procps-ng-$(PROCPS_NG_VERSION).tar.xz
PROCPS_NG_SITE = http://downloads.sourceforge.net/project/procps-ng/Production
PROCPS_NG_LICENSE = GPL-2.0+, LGPL-2.0+ (libproc and libps)
PROCPS_NG_LICENSE_FILES = COPYING COPYING.LIB
PROCPS_NG_CPE_ID_VENDOR = procps-ng_project
PROCPS_NG_INSTALL_STAGING = YES
# We're patching configure.ac
PROCPS_NG_AUTORECONF = YES
PROCPS_NG_DEPENDENCIES = ncurses host-pkgconf $(TARGET_NLS_DEPENDENCIES)
PROCPS_NG_CONF_OPTS = LIBS=$(TARGET_NLS_LIBS)
@ -45,6 +47,13 @@ ifeq ($(BR2_STATIC_LIBS),y)
PROCPS_NG_CONF_OPTS += --disable-numa
endif
# w requires utmp.h
ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
PROCPS_NG_CONF_OPTS += --disable-w
else
PROCPS_NG_CONF_OPTS += --enable-w
endif
# Avoid installing S02sysctl, since openrc provides /etc/init.d/sysctl.
define PROCPS_NG_INSTALL_INIT_OPENRC
@: