New Package: latencytop

[Peter: fix Config.in location]
Signed-off-by: Qais Yousef <qais.yousef@imgtec.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
This commit is contained in:
Qais Yousef 2012-04-18 01:06:00 +00:00 committed by Peter Korsgaard
parent 94c297c448
commit cd2f78b1c5
4 changed files with 73 additions and 0 deletions

View file

@ -22,6 +22,7 @@ source "package/dhrystone/Config.in"
source "package/dstat/Config.in"
source "package/dmalloc/Config.in"
source "package/kexec/Config.in"
source "package/latencytop/Config.in"
source "package/lmbench/Config.in"
source "package/lsof/Config.in"
source "package/ltp-testsuite/Config.in"

View file

@ -0,0 +1,23 @@
config BR2_PACKAGE_LATENCYTOP
bool "latencytop"
depends on BR2_USE_WCHAR
select BR2_PACKAGE_NCURSES
select BR2_PACKAGE_LIBGLIB2
help
There are many types and causes of latency. LatencyTOP
focuses on the type of latency that causes skips in audio,
stutters in your desktop experience or that overloads your
server (while you have plenty of CPU power left).
LatencyTOP focuses on the cases where the applications want
to run and execute useful code, but there's some resource
that's not currently available (and the kernel then blocks
the process). This is done both on a system level and on a
per process level, so that you can see what's happening to
the system, and which process is suffering and/or causing
the delays.
http://www.latencytop.org
comment "latencytop requires a toolchain with WCHAR support"
depends on !BR2_USE_WCHAR

View file

@ -0,0 +1,28 @@
Usee $(CC) to enable cross compiling and link to the right ncurses library.
Signed-off-by: Qais Yousef <qais.yousef@imgtec.com>
--- latencytop-0.5/Makefile.old 2012-04-18 11:59:39.748084334 +0100
+++ latencytop-0.5/Makefile 2012-04-18 12:00:08.659112340 +0100
@@ -4,7 +4,7 @@
DESTDIR =
SBINDIR = /usr/sbin
XCFLAGS = -W -g `pkg-config --cflags glib-2.0` -D_FORTIFY_SOURCE=2 -Wno-sign-compare
-LDF = -Wl,--as-needed `pkg-config --libs glib-2.0` -lncursesw
+LDF = -Wl,--as-needed `pkg-config --libs glib-2.0` -lncurses
OBJS= latencytop.o text_display.o translate.o fsync.o
@@ -26,10 +26,10 @@
# We write explicity this "implicit rule"
%.o : %.c
- gcc -c $(CFLAGS) $(XCFLAGS) $< -o $@
+ $(CC) -c $(CFLAGS) $(XCFLAGS) $< -o $@
latencytop: $(OBJS) latencytop.h Makefile
- gcc $(CFLAGS) $(OBJS) $(LDF) -o latencytop
+ $(CC) $(CFLAGS) $(OBJS) $(LDF) -o latencytop
clean:
rm -f *~ latencytop DEADJOE *.o

View file

@ -0,0 +1,21 @@
#############################################################
#
# latencytop
#
#############################################################
LATENCYTOP_VERSION = 0.5
LATENCYTOP_SITE = http://www.latencytop.org/download/
LATENCYTOP_DEPENDENCIES = libglib2 ncurses
# NOTE: GTK is heavy weight, we intentionally build the text (ncurses)
# version only
define LATENCYTOP_BUILD_CMDS
$(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) HAS_GTK_GUI=
endef
define LATENCYTOP_INSTALL_TARGET_CMDS
$(MAKE) install -C $(@D) DESTDIR=$(TARGET_DIR) HAS_GTK_GUI=
endef
$(eval $(call GENTARGETS))