redis: bump to version 2.8.19

Add hash file.
Drop redis-002-lua-AR.patch (upstream).
Rename patches to new naming convention.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
Gustavo Zacarias 2015-01-21 09:21:42 -03:00 committed by Peter Korsgaard
parent 9a4d760e1b
commit d226500192
6 changed files with 7 additions and 35 deletions

View file

@ -3,6 +3,7 @@ config BR2_PACKAGE_REDIS
depends on BR2_USE_MMU # fork()
depends on BR2_TOOLCHAIN_HAS_THREADS
depends on BR2_LARGEFILE
depends on BR2_INET_IPV6
help
Redis is an open source, advanced key-value store. It is
often referred to as a data structure server since keys can
@ -10,6 +11,7 @@ config BR2_PACKAGE_REDIS
http://www.redis.io
comment "redis needs a toolchain w/ largefile, threads"
comment "redis needs a toolchain w/ IPv6, largefile, threads"
depends on BR2_USE_MMU
depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS \
|| !BR2_INET_IPV6

View file

@ -1,32 +0,0 @@
redis-002-lua-AR.patch: Improve redis Makefiles to handle Lua's unusual
definition of AR. Patch originates from:
Define AR to help with lua cross-compilation
https://github.com/antirez/redis/pull/997
Daniel Price, daniel.price@gmail.com
Signed-off-by: Daniel Price <daniel.price@gmail.com>
=========================================================================
diff --git a/deps/Makefile b/deps/Makefile
index d58ee56..c9d7116 100644
--- a/deps/Makefile
+++ b/deps/Makefile
@@ -60,10 +60,15 @@ endif
LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI $(CFLAGS)
LUA_LDFLAGS+= $(LDFLAGS)
+# lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
+# challenging to cross-compile lua (and redis). These defines make it easier
+# to fit redis into cross-compilation environments, which typically set AR.
+AR = ar
+ARFLAGS = rcu
lua: .make-prerequisites
@printf '%b %b\n' $(MAKECOLOR)MAKE$(ENDCOLOR) $(BINCOLOR)$@$(ENDCOLOR)
- cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)"
+ cd lua/src && $(MAKE) all CFLAGS="$(LUA_CFLAGS)" MYLDFLAGS="$(LUA_LDFLAGS)" AR="$(AR) $(ARFLAGS)"
.PHONY: lua

2
package/redis/redis.hash Normal file
View file

@ -0,0 +1,2 @@
# Locally calculated
sha256 29bb08abfc3d392b2f0c3e7f48ec46dd09ab1023f9a5575fc2a93546f4ca5145 redis-2.8.19.tar.gz

View file

@ -4,7 +4,7 @@
#
################################################################################
REDIS_VERSION = 2.6.17
REDIS_VERSION = 2.8.19
REDIS_SITE = http://download.redis.io/releases
REDIS_LICENSE = BSD-3c (core); MIT and BSD family licenses (Bundled components)
REDIS_LICENSE_FILES = COPYING