syslinux: bump to 4.05

* bump syslinux from 4.04 to 4.05
* add patch to fix build problem with 4.05, see
http://old.nabble.com/syslinux-fails-to-build-td34112447.html
* add util-linux dependency and make sure the build finds it

Signed-off-by: Aras Vaichas <aras.vaichas@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Aras Vaichas 2012-07-05 22:01:31 +02:00 committed by Thomas Petazzoni
parent 8278ed43ef
commit d2ff1ac2b3
2 changed files with 21 additions and 3 deletions

View file

@ -0,0 +1,15 @@
Author: Micah Gersten <micahg@ubuntu.com>
Description: Fix build failure with --as-needed (Closes: #654838).
diff -Naurp syslinux.orig/utils/Makefile syslinux/utils/Makefile
--- syslinux.orig/utils/Makefile 2011-12-23 14:53:26.653571511 +0100
+++ syslinux/utils/Makefile 2012-01-22 18:55:03.849466924 +0100
@@ -51,7 +51,7 @@ isohdpfx.c: $(ISOHDPFX) isohdpfxarray.pl
$(PERL) isohdpfxarray.pl $(ISOHDPFX) > $@
isohybrid: isohybrid.o isohdpfx.o
- $(CC) $(LDFLAGS) -luuid -o $@ $^
+ $(CC) $(LDFLAGS) -o $@ $^ -luuid
gethostip: gethostip.o
$(CC) $(LDFLAGS) -o $@ $^

View file

@ -4,17 +4,20 @@
#
#############################################################
SYSLINUX_VERSION = 4.04
SYSLINUX_VERSION = 4.05
SYSLINUX_SOURCE = syslinux-$(SYSLINUX_VERSION).tar.bz2
SYSLINUX_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/boot/syslinux/4.xx/
SYSLINUX_INSTALL_TARGET = NO
SYSLINUX_INSTALL_IMAGES = YES
SYSLINUX_DEPENDENCIES = host-nasm
SYSLINUX_DEPENDENCIES = host-nasm host-util-linux
# syslinux build system has no convenient way to pass CFLAGS,
# and the internal zlib should take precedence so -I shouldn't
# be used.
define SYSLINUX_BUILD_CMDS
$(TARGET_MAKE_ENV) $(MAKE) CC="$(HOSTCC)" AR="$(HOSTAR)" -C $(@D)
$(TARGET_MAKE_ENV) $(MAKE) CC="$(HOSTCC) -idirafter $(HOST_DIR)/usr/include $(HOST_LDFLAGS)" AR="$(HOSTAR)" -C $(@D)
endef
SYSLINUX_IMAGES-$(BR2_TARGET_SYSLINUX_ISOLINUX) += isolinux.bin