package/leveldb: bump to version 1.23

- Refresh second and fourth patches
- Update indentation in hash file (two spaces)

https://github.com/google/leveldb/releases/tag/1.23

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
This commit is contained in:
Fabrice Fontaine 2021-12-15 00:04:08 +01:00 committed by Arnout Vandecappelle (Essensium/Mind)
parent d8bee3950a
commit dc929dfa4d
4 changed files with 12 additions and 8 deletions

View file

@ -8,6 +8,8 @@ https://git.busybox.net/buildroot/commit/?id=8a10d9ce311c6cb0490d76921cae55618c2
https://git.busybox.net/buildroot/commit/?id=16f847340d07dce620e4c3fc0a099aa79898d86a
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Fabrice : updated for 1.23]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
CMakeLists.txt | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)
@ -48,9 +50,9 @@ index a65afbf..83b2425 100644
target_sources(leveldb
PRIVATE
@@ -418,7 +436,7 @@ endif(LEVELDB_BUILD_BENCHMARKS)
endif(LEVELDB_BUILD_BENCHMARKS)
if(LEVELDB_INSTALL)
include(GNUInstallDirs)
- install(TARGETS leveldb
+ install(TARGETS leveldb memenv
EXPORT leveldbTargets

View file

@ -7,6 +7,8 @@ Upstream: https://github.com/google/leveldb/pull/686/commits/3e73a396a082efc76e0
[Thomas: this commit allows to fix the detection of the snappy library
in static link configurations]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
[Fabrice : updated for 1.23]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
CMakeLists.txt | 12 ++++++++----
cmake/FindSnappy.cmake | 31 +++++++++++++++++++++++++++++++
@ -19,14 +21,14 @@ index 78fead6..2efccda 100644
+++ b/CMakeLists.txt
@@ -6,6 +6,9 @@ cmake_minimum_required(VERSION 3.9)
# Keep the version below in sync with the one in db.h
project(leveldb VERSION 1.22.0 LANGUAGES C CXX)
project(leveldb VERSION 1.23.0 LANGUAGES C CXX)
+# Include local CMake modules.
+list(APPEND CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
+
# This project can use C11, but will gracefully decay down to C89.
set(CMAKE_C_STANDARD 11)
set(CMAKE_C_STANDARD_REQUIRED OFF)
# C standard can be overridden when this is used as a sub-project.
if(NOT CMAKE_C_STANDARD)
# This project can use C11, but will gracefully decay down to C89.
@@ -31,13 +34,14 @@ option(LEVELDB_INSTALL "Install LevelDB's header and library" ON)
include(TestBigEndian)
test_big_endian(LEVELDB_IS_BIG_ENDIAN)

View file

@ -1,3 +1,3 @@
# Locally calculated
sha256 55423cac9e3306f4a9502c738a001e4a339d1a38ffbee7572d4a07d5d63949b2 leveldb-1.22.tar.gz
sha256 ccc19f1da0798ed666609b65a5b44dd8b3abe6fc08b9c0592eb76e82e174db19 LICENSE
sha256 9a37f8a6174f09bd622bc723b55881dc541cd50747cbd08831c2a82d620f6d76 leveldb-1.23.tar.gz
sha256 ccc19f1da0798ed666609b65a5b44dd8b3abe6fc08b9c0592eb76e82e174db19 LICENSE

View file

@ -4,7 +4,7 @@
#
################################################################################
LEVELDB_VERSION = 1.22
LEVELDB_VERSION = 1.23
LEVELDB_SITE = $(call github,google,leveldb,$(LEVELDB_VERSION))
LEVELDB_LICENSE = BSD-3-Clause
LEVELDB_LICENSE_FILES = LICENSE