package/catatonit: new package

catatonit is a simple but valid init binary to act as PID 1 for containers.

https://github.com/openSUSE/catatonit

Dependency of podman.

Signed-off-by: Christian Stewart <christian@paral.in>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
This commit is contained in:
Christian Stewart 2022-08-20 21:14:17 -07:00 committed by Thomas Petazzoni
parent 8369ff62db
commit e3975ec7d4
6 changed files with 68 additions and 0 deletions

View file

@ -533,6 +533,7 @@ F: package/python-pylibftdi/
N: Christian Stewart <christian@paral.in>
F: package/batman-adv/
F: package/catatonit/
F: package/containerd/
F: package/crun/
F: package/delve/

View file

@ -2531,6 +2531,7 @@ comment "Utilities"
source "package/apg/Config.in"
source "package/at/Config.in"
source "package/bash-completion/Config.in"
source "package/catatonit/Config.in"
source "package/ccrypt/Config.in"
source "package/crudini/Config.in"
source "package/dialog/Config.in"

View file

@ -0,0 +1,41 @@
From 99bb9048f532257f3a2c3856cfa19fe957ab6cec Mon Sep 17 00:00:00 2001
From: Antonio Terceiro <terceiro@debian.org>
Date: Thu, 4 Nov 2021 07:37:13 -0300
Subject: [PATCH] configure.ac: call AM_INIT_AUTOMAKE only once
That second call seems to be there since the beginning, and autoconf
2.69 was fine with it. autoconf 2.71 doesn't allow it anymore:
$ ./autogen.sh
autoreconf: export WARNINGS=
autoreconf: Entering directory '.'
autoreconf: configure.ac: not using Gettext
autoreconf: running: aclocal --force
configure.ac:34: error: AM_INIT_AUTOMAKE expanded multiple times
/usr/share/aclocal-1.16/init.m4:29: AM_INIT_AUTOMAKE is expanded from...
configure.ac:19: the top level
/usr/share/aclocal-1.16/init.m4:29: AM_INIT_AUTOMAKE is expanded from...
configure.ac:34: the top level
autom4te: error: /usr/bin/m4 failed with exit status: 1
aclocal: error: /usr/bin/autom4te failed with exit status: 1
autoreconf: error: aclocal failed with exit status: 1
Signed-off-by: Antonio Terceiro <terceiro@debian.org>
Upstream: https://github.com/openSUSE/catatonit/commit/99bb9048f532257f3a2c3856cfa19fe957ab6cec
Signed-off-by: Christian Stewart <christian@paral.in>
---
configure.ac | 1 -
1 file changed, 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 12c9186..94c5c84 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,4 +31,3 @@ AC_FUNC_FORK
AC_CONFIG_FILES([Makefile config.h])
AC_OUTPUT
-AM_INIT_AUTOMAKE
--
2.37.2

View file

@ -0,0 +1,8 @@
config BR2_PACKAGE_CATATONIT
bool "catatonit"
depends on BR2_USE_MMU
help
catatonit is a simple but valid init binary to act as
PID 1 for containers.
https://github.com/openSUSE/catatonit

View file

@ -0,0 +1,3 @@
# Locally computed
sha256 e22bc72ebc23762dad8f5d2ed9d5ab1aaad567bdd54422f1d1da775277a93296 catatonit-0.1.7.tar.gz
sha256 3972dc9744f6499f0f9b2dbf76696f2ae7ad8af9b23dde66d6af86c9dfb36986 COPYING

View file

@ -0,0 +1,14 @@
################################################################################
#
# catatonit
#
################################################################################
CATATONIT_VERSION = 0.1.7
CATATONIT_SITE = $(call github,openSUSE,catatonit,v$(CATATONIT_VERSION))
CATATONIT_LICENSE = GPL-3.0+
CATATONIT_LICENSE_FILES = COPYING
CATATONIT_AUTORECONF = YES
$(eval $(autotools-package))