package/pipewire: bump to version 0.3.45

Drop patch that is now upstream.

Set new x11 and libcanberra meson config options.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
This commit is contained in:
James Hilliard 2022-02-05 17:37:46 -07:00 committed by Peter Korsgaard
parent f4da031a77
commit e6a2903946
3 changed files with 10 additions and 42 deletions

View file

@ -1,40 +0,0 @@
From 8d9dc023ac12cf305c28786891d5b15e13f29a3d Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Tue, 25 Jan 2022 17:22:02 +0100
Subject: [PATCH] spa/meson.build: add atomic_dep dependency
Commit fa64d93e64592d5edd8767f722cf4ea093641052 moved the atomic_dep
from pipewire-jack to pipewire_dep however atomic_dep should also be
added to spa_dev to avoid the following build failure when building
examples (which don't depend on pipewire_dep):
FAILED: spa/examples/adapter-control
/home/buildroot/autobuild/instance-0/output-1/host/bin/sparc-linux-gcc -o spa/examples/adapter-control spa/examples/adapter-control.p/adapter-control.c.o -Wl,--as-needed -Wl,--no-undefined -Wl,-O1 -Wl,--start-group -lintl -ldl -pthread -lm -Wl,--end-group
/home/buildroot/autobuild/instance-0/output-1/host/opt/ext-toolchain/bin/../lib/gcc/sparc-buildroot-linux-uclibc/10.3.0/../../../../sparc-buildroot-linux-uclibc/bin/ld: spa/examples/adapter-control.p/adapter-control.c.o: in function `spa_graph_node_trigger':
adapter-control.c:(.text+0xdf4): undefined reference to `__atomic_fetch_sub_4'
Fixes:
- http://autobuild.buildroot.org/results/192f40a5c6e05fc11507494e19db52a47082fc35
[Retrieved from:
https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/8d9dc023ac12cf305c28786891d5b15e13f29a3d]
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
---
spa/meson.build | 1 +
1 file changed, 1 insertion(+)
diff --git a/spa/meson.build b/spa/meson.build
index 4ad37cdb4..2404748df 100644
--- a/spa/meson.build
+++ b/spa/meson.build
@@ -9,6 +9,7 @@ spa_dep = declare_dependency(
include_directories : [
include_directories('include'),
],
+ dependencies : [atomic_dep],
version : spaversion,
variables : {
'plugindir' : meson.current_build_dir() / 'plugins',
--
GitLab

View file

@ -1,4 +1,4 @@
# Locally calculated
sha256 2e91f228ffb93494f2423956b930014de20e15639a03f3df4fca4ebf4bc51fc0 pipewire-0.3.43.tar.bz2
sha256 76291373f7ab271664df5b6a22b678ad57e485e25c73ee9c78e049a67b7886d2 pipewire-0.3.45.tar.bz2
sha256 8909c319a7e27dbb33a15b9035f89ab3b7b2f6a12f8bcddc755206a8db1ada44 COPYING
sha256 be4be5d77424833edf31f53fc1f1cecb6996b9e2d747d9e6fb8f878362ebc92b LICENSE

View file

@ -4,7 +4,7 @@
#
################################################################################
PIPEWIRE_VERSION = 0.3.43
PIPEWIRE_VERSION = 0.3.45
PIPEWIRE_SOURCE = pipewire-$(PIPEWIRE_VERSION).tar.bz2
PIPEWIRE_SITE = https://gitlab.freedesktop.org/pipewire/pipewire/-/archive/$(PIPEWIRE_VERSION)
PIPEWIRE_LICENSE = MIT, LGPL-2.1+ (libspa-alsa), GPL-2.0 (libjackserver)
@ -29,6 +29,7 @@ PIPEWIRE_CONF_OPTS += \
-Dvideotestsrc=enabled \
-Dvolume=enabled \
-Dsession-managers=[] \
-Dlibcanberra=disabled \
-Dlv2=disabled
ifeq ($(BR2_PACKAGE_DBUS),y)
@ -128,6 +129,13 @@ else
PIPEWIRE_CONF_OPTS += -Dlibcamera=disabled
endif
ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
PIPEWIRE_CONF_OPTS += -Dx11=enabled
PIPEWIRE_DEPENDENCIES += xlib_libX11
else
PIPEWIRE_CONF_OPTS += -Dx11=disabled
endif
ifeq ($(BR2_PACKAGE_LIBUSB),y)
PIPEWIRE_CONF_OPTS += -Dlibusb=enabled
PIPEWIRE_DEPENDENCIES += libusb