package/dbus-cpp: fix cross-compilation

dbus-cpp has an ugly hack to not cross-build the tools when it detects
cross-compilation.

However, we already have a host variant that builds those tools (and we
anyway don't seem to need them to begin with).

Drop our patch that propagates the CXXFLAGS/LDFLAGS_FOR_BUILD. Replace
with a patch to cross-compile the tools.

Fixes:
    http://autobuild.buildroot.org/results/110/1100539caae6ef62c61a3b96bc54f7c0a215cc62/
    and many, many more.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Yann E. MORIN 2017-03-21 22:33:59 +01:00 committed by Thomas Petazzoni
parent ee8cbc5fca
commit f5dbd0dea1
2 changed files with 34 additions and 32 deletions

View file

@ -0,0 +1,34 @@
tools: just do proper cross-compile
Those tools are not used during the build; besides, they are installed.
So they don't need to not be cross-compiled.
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
---
Upstream status: not submitted, upstream is dead.
diff -durN dbus-cpp-0.9.0.orig/tools/Makefile.am dbus-cpp-0.9.0/tools/Makefile.am
--- dbus-cpp-0.9.0.orig/tools/Makefile.am 2017-03-21 21:48:57.013409423 +0100
+++ dbus-cpp-0.9.0/tools/Makefile.am 2017-03-21 21:49:35.329979798 +0100
@@ -1,7 +1,3 @@
-# hacky, but ...
-
-CXX = $(CXX_FOR_BUILD)
-
AM_CPPFLAGS = \
$(dbus_CFLAGS) \
$(xml_CFLAGS) \
@@ -9,11 +3,7 @@
-I$(top_builddir)/include \
-Wall
-if CROSS_COMPILING
-libdbus_cxx_la = $(BUILD_LIBDBUS_CXX_DIR)/src/libdbus-c++-1.la
-else
libdbus_cxx_la = $(top_builddir)/src/libdbus-c++-1.la
-endif
bin_PROGRAMS = dbusxx-xml2cpp dbusxx-introspect

View file

@ -1,32 +0,0 @@
Use CXXFLAGS_FOR_BUILD and LDFLAGS_FOR_BUILD for the tools since expat
may not be living in the default include & library path.
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
diff -Nura libdbus-c++-0.9.0.orig/configure.ac libdbus-c++-0.9.0/configure.ac
--- libdbus-c++-0.9.0.orig/configure.ac 2014-01-05 15:28:03.653886567 -0300
+++ libdbus-c++-0.9.0/configure.ac 2014-01-05 15:44:32.571172225 -0300
@@ -65,7 +65,11 @@
AC_PROG_CXX
CXX_FOR_BUILD=${CXX_FOR_BUILD-${CXX}}
+CXXFLAGS_FOR_BUILD=${CXXFLAGS_FOR_BUILD-${CXXFLAGS}}
+LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
AC_SUBST(CXX_FOR_BUILD)
+AC_SUBST(CXXFLAGS_FOR_BUILD)
+AC_SUBST(LDFLAGS_FOR_BUILD)
AM_PROG_LIBTOOL
diff -Nura libdbus-c++-0.9.0.orig/tools/Makefile.am libdbus-c++-0.9.0/tools/Makefile.am
--- libdbus-c++-0.9.0.orig/tools/Makefile.am 2014-01-05 15:28:03.652886535 -0300
+++ libdbus-c++-0.9.0/tools/Makefile.am 2014-01-05 15:44:42.071482390 -0300
@@ -1,6 +1,8 @@
# hacky, but ...
CXX = $(CXX_FOR_BUILD)
+CXXFLAGS = $(CXXFLAGS_FOR_BUILD)
+LDFLAGS = $(LDFLAGS_FOR_BUILD)
AM_CPPFLAGS = \
$(dbus_CFLAGS) \