webkit: remove deprecated package

It's been deprecated for quite a while and it's now replaced by the more
modern and up to date webkitgtk package.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
This commit is contained in:
Gustavo Zacarias 2016-09-08 15:38:59 -03:00 committed by Thomas Petazzoni
parent 3d6c484367
commit f617deaa90
12 changed files with 0 additions and 1880 deletions

View file

@ -994,7 +994,6 @@ menu "Graphics"
source "package/tiff/Config.in"
source "package/wayland/Config.in"
source "package/wayland-protocols/Config.in"
source "package/webkit/Config.in"
source "package/webkitgtk/Config.in"
source "package/webkitgtk24/Config.in"
source "package/webp/Config.in"

View file

@ -1,34 +0,0 @@
Add missing symbol for WebCore::TextIterator::getLocationAndLengthFromRange
Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
From f5bb58f9096061f00c948e668335811d364ba360 Mon Sep 17 00:00:00 2001
From: "kov@webkit.org" <kov@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date: Thu, 7 Feb 2013 13:48:46 +0000
Subject: [PATCH] Unreviewed build fix after r141196 for 32 bits autotools.
* Source/autotools/symbols.filter: restore 32 bits version of the
WebCore::TextIterator::getLocationAndLengthFromRange(WebCore::Node*,
WebCore::Range const*, unsigned int&, unsigned int&) symbol.
git-svn-id: http://svn.webkit.org/repository/webkit/trunk@142105 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
ChangeLog | 8 ++++++++
Source/autotools/symbols.filter | 1 +
2 files changed, 9 insertions(+)
diff --git a/Source/autotools/symbols.filter b/Source/autotools/symbols.filter
index 9d730b3..2edefaf 100644
--- a/Source/autotools/symbols.filter
+++ b/Source/autotools/symbols.filter
@@ -57,6 +57,7 @@ _ZN7WebCore11HistoryItem16setDocumentStateERKN3WTF6VectorINS1_6StringELj0EEE;
_ZN7WebCore11HistoryItem16setDocumentStateERKN3WTF6VectorINS1_6StringELm0EEE;
_ZN7WebCore11MemoryCache14resourceForURLERKNS_4KURLE;
_ZN7WebCore12TextIterator26rangeFromLocationAndLengthEPNS_13ContainerNodeEiib;
+_ZN7WebCore12TextIterator29getLocationAndLengthFromRangeEPNS_4NodeEPKNS_5RangeERjS6_;
_ZN7WebCore12TextIterator29getLocationAndLengthFromRangeEPNS_4NodeEPKNS_5RangeERmS6_;
_ZN7WebCore12PrintContext20pageNumberForElementEPNS_7ElementERKNS_9FloatSizeE;
_ZN7WebCore13createWrapperEPN3JSC9ExecStateEPNS_17JSDOMGlobalObjectEPNS_4NodeE;
--
1.8.3.2

View file

@ -1,51 +0,0 @@
Make gstreamer support conditional
Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
From f1055f61bce46eccf8dc0aa017113a08d3d71944 Mon Sep 17 00:00:00 2001
From: "commit-queue@webkit.org"
<commit-queue@webkit.org@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
Date: Fri, 15 Mar 2013 07:13:51 +0000
Subject: [PATCH] Build fix for Tools/GtkLauncher/Programs_GtkLauncher-main.o
if gstreamer is not installed https://bugs.webkit.org/show_bug.cgi?id=112394
Patch by Tobias Mueller <tobiasmue@gnome.org> on 2013-03-15
Reviewed by Philippe Normand.
* GtkLauncher/main.c:
(main): Guard using the gstreamer function with #ifdef WTF_USE_GSTREAMER
git-svn-id: http://svn.webkit.org/repository/webkit/trunk@145881 268f45cc-cd09-0410-ab3c-d52691b4dbfc
---
Tools/ChangeLog | 10 ++++++++++
Tools/GtkLauncher/main.c | 5 ++++-
2 files changed, 14 insertions(+), 1 deletion(-)
diff --git a/Tools/GtkLauncher/main.c b/Tools/GtkLauncher/main.c
index 32baf4a..84c8833 100644
--- a/Tools/GtkLauncher/main.c
+++ b/Tools/GtkLauncher/main.c
@@ -28,7 +28,9 @@
#include "autotoolsconfig.h"
#include "LauncherInspectorWindow.h"
#include <errno.h>
+#ifdef WTF_USE_GSTREAMER
#include <gst/gst.h>
+#endif
#include <gtk/gtk.h>
#include <stdlib.h>
#include <string.h>
@@ -489,8 +491,9 @@ int main(int argc, char* argv[])
GOptionContext *context = g_option_context_new(0);
g_option_context_add_main_entries(context, commandLineOptions, 0);
g_option_context_add_group(context, gtk_get_option_group(TRUE));
+#ifdef WTF_USE_GSTREAMER
g_option_context_add_group(context, gst_init_get_option_group());
-
+#endif
webkitSettings = webkit_web_settings_new();
g_object_set(webkitSettings, "enable-developer-extras", TRUE, NULL);
if (!addWebSettingsGroupToContext(context, webkitSettings)) {
--
1.8.3.2

View file

@ -1,28 +0,0 @@
harfbuzz-icu detections based on the following upstream commits
- 5f3ae29ffb29c499c1825578ba7f3ffcbf1aa8b9
- ad2a23ec44b692bde43a13b658990770caa8dfc5
- 22b4786377142424bfb6562ff029997acd0846d1
Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
Index: webkit-1.11.5/configure.ac
===================================================================
--- webkit-1.11.5.orig/configure.ac
+++ webkit-1.11.5/configure.ac
@@ -938,6 +938,15 @@ PKG_CHECK_MODULES([FREETYPE],
freetype2 >= $FREETYPE2_REQUIRED_VERSION
harfbuzz])
fi
+# HarfBuzz 0.9.18 splits harbuzz-icu into a separate library.
+# Since we support earlier HarfBuzz versions we keep this conditional for now.
+m4_define([harfbuzz_required_version], [0.9.7])
+if $PKG_CONFIG --atleast-version 0.9.18 harfbuzz; then
+ PKG_CHECK_MODULES([HARFBUZZ_ICU], [harfbuzz-icu >= $harfbuzz_required_version])
+ FREETYPE_CFLAGS+=" $HARFBUZZ_ICU_CFLAGS"
+ FREETYPE_LIBS+=" $HARFBUZZ_ICU_LIBS"
+fi
+
AC_SUBST([FREETYPE_CFLAGS])
AC_SUBST([FREETYPE_LIBS])

View file

@ -1,27 +0,0 @@
This patch prevents documentation from being rebased or installed. This
prevents an error when gtk-doc --rebase is called.
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-off-by: Markos Chandras <markos.chandras@imgtec.com>
Index: webkit-1.11.5/Tools/GNUmakefile.am
===================================================================
--- webkit-1.11.5.orig/Tools/GNUmakefile.am
+++ webkit-1.11.5/Tools/GNUmakefile.am
@@ -308,6 +308,8 @@ EXTRA_DIST += \
Tools/Scripts/webkit-build-directory \
Tools/Scripts/webkitdirs.pm
+if ENABLE_GTK_DOC
+
docs: docs-build.stamp
.PHONY : docs
DISTCLEANFILES += docs-build.stamp
@@ -412,7 +414,6 @@ if ENABLE_WEBKIT2
rm -rf $${installdir}
endif
-if ENABLE_GTK_DOC
all: docs-build.stamp
endif

View file

@ -1,80 +0,0 @@
This prevents the Webkit test suites from being built.
Signed-off-by: Spenser Gilliland <spenser@gillilanding.com>
----
Index: webkit-1.9.6/GNUmakefile.am
===================================================================
--- webkit-1.9.6.orig/GNUmakefile.am 2012-08-06 03:17:24.000000000 -0500
+++ webkit-1.9.6/GNUmakefile.am 2013-05-28 10:08:53.645129501 -0500
@@ -282,11 +282,14 @@
include Tools/DumpRenderTree/gtk/GNUmakefile.ImageDiff.am
include Source/WebKit2/GNUmakefile.am
-include Source/WebKit2/UIProcess/API/gtk/tests/GNUmakefile.am
include Tools/MiniBrowser/gtk/GNUmakefile.am
+
+if ENABLE_TESTS
+include Source/WebKit2/UIProcess/API/gtk/tests/GNUmakefile.am
include Tools/WebKitTestRunner/GNUmakefile.am
include Source/ThirdParty/gtest/GNUmakefile.am
include Tools/TestWebKitAPI/GNUmakefile.am
+endif # ENABLE_TESTS
# [GTK] Refactor the translations now that we have webkit2
# https://bugs.webkit.org/show_bug.cgi?id=55153
Index: webkit-1.9.6/Source/WebKit/gtk/GNUmakefile.am
===================================================================
--- webkit-1.9.6.orig/Source/WebKit/gtk/GNUmakefile.am 2012-07-19 05:02:29.000000000 -0500
+++ webkit-1.9.6/Source/WebKit/gtk/GNUmakefile.am 2013-05-28 10:09:49.277130516 -0500
@@ -413,6 +413,7 @@
dist_resources_DATA = \
$(shell ls $(srcdir)/Source/WebKit/gtk/resources/*.html)
+if ENABLE_TESTS
# Build unit tests
webkit_tests_cflags = \
-fno-strict-aliasing \
@@ -613,6 +614,8 @@
Programs_unittests_testcopyandpaste_LDADD = $(webkit_tests_ldadd)
Programs_unittests_testcopyandpaste_LDFLAGS = $(webkit_tests_ldflags)
+endif # ENABLE_TESTS
+
# Project-wide clean rules
# Files that will be cleaned
CLEANFILES += \
Index: webkit-1.9.6/configure.ac
===================================================================
--- webkit-1.9.6.orig/configure.ac 2012-08-06 08:45:10.000000000 -0500
+++ webkit-1.9.6/configure.ac 2013-05-28 10:07:55.817128445 -0500
@@ -516,6 +516,14 @@
AC_SUBST(CAIRO_CFLAGS)
AC_SUBST(CAIRO_LIBS)
+# check wheter to build tests
+AC_MSG_CHECKING([wheter to build tests])
+AC_ARG_ENABLE(tests,
+ AC_HELP_STRING([--enable-tests],
+ [turn on tests [default=no]]),
+ [],[enable_debug="no"])
+AC_MSG_RESULT([$enable_tests])
+
# check whether to build with debugging enabled
AC_MSG_CHECKING([whether to do a debug build])
AC_ARG_ENABLE(debug,
@@ -1423,6 +1431,7 @@
AM_CONDITIONAL([USE_FARSTREAM], [test "$have_farstream" = "yes"])
# WebKit feature conditionals
+AM_CONDITIONAL([ENABLE_TESTS],[test "$enable_tests" = "yes"])
AM_CONDITIONAL([ENABLE_DEBUG],[test "$enable_debug_features" = "yes"])
AM_CONDITIONAL([ENABLE_UNSTABLE_FEATURES],[test "$enable_unstable_features" = "yes"])
AM_CONDITIONAL([ENABLE_WEBGL],[test "$enable_webgl" = "yes"])
@@ -1534,6 +1543,7 @@
WebKit was configured with the following options:
Build configuration:
+ Enable tests (slow) : $enable_tests
Enable debugging (slow) : $enable_debug
Compile with debug symbols (slow) : $enable_debug_symbols
Enable debug features (slow) : $enable_debug_features

View file

@ -1,20 +0,0 @@
Fixes uclibc build as uclibc does not include backtrace functionality
Signed-of-by: Spenser Gilliland <spenser@gillilanding.com>
Signed-of-by: Markos Chandras <markos.chandras@imgtec.com>
Index: webkit-1.11.5/Source/WTF/wtf/Assertions.cpp
===================================================================
--- webkit-1.11.5.orig/Source/WTF/wtf/Assertions.cpp
+++ webkit-1.11.5/Source/WTF/wtf/Assertions.cpp
@@ -61,8 +61,10 @@
#if (OS(DARWIN) || (OS(LINUX) && !defined(__UCLIBC__))) && !OS(ANDROID)
#include <cxxabi.h>
#include <dlfcn.h>
+#if !defined(__UCLIBC__)
#include <execinfo.h>
#endif
+#endif
#if OS(ANDROID)
#include "android/log.h"

File diff suppressed because it is too large Load diff

View file

@ -1,22 +0,0 @@
ANGLE doesn't build with bison 3.0
Author: allan.jensen@digia.com
https://bugs.webkit.org/show_bug.cgi?id=119798
Reviewed by Antti Koivisto.
Make glslang.y compatible with bison 3.0, by using %lex-param
to set YYLEX_PARAM and getting rid of useless YYID macro.
From upstream: http://trac.webkit.org/changeset/154109
[Arnout: adapted to our older webkit version]
Signed-off-by: Arnout Vandecaeppelle (Essensium/Mind) <arnout@mind.be>
---
Index: trunk/Source/ThirdParty/ANGLE/src/compiler/glslang.y
===================================================================
--- trunk/Source/ThirdParty/ANGLE/src/compiler/glslang.y (revision 154108)
+++ trunk/Source/ThirdParty/ANGLE/src/compiler/glslang.y (revision 154109)
@@ -48,4 +48,5 @@
%pure-parser
%parse-param {TParseContext* context}
+%lex-param {YYLEX_PARAM}
%union {

View file

@ -1,53 +0,0 @@
config BR2_PACKAGE_WEBKIT_ARCH_SUPPORTS
bool
# ARM needs BLX, so v5t+
default y if (BR2_arm || BR2_armeb) && !BR2_ARM_CPU_ARMV4
default y if BR2_i386 || BR2_mips || BR2_mipsel || \
BR2_sparc || BR2_x86_64
depends on BR2_USE_MMU # libgail -> pango -> libglib2
depends on BR2_DEPRECATED_SINCE_2015_08
# disabled on powerpc due to bug https://bugs.webkit.org/show_bug.cgi?id=113638
config BR2_PACKAGE_WEBKIT
bool "webkit"
depends on BR2_DEPRECATED_SINCE_2015_08
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_USE_WCHAR # enchant -> libglib2
depends on BR2_TOOLCHAIN_HAS_THREADS # enchant -> libglib2; icu
depends on BR2_PACKAGE_LIBGTK2
depends on BR2_PACKAGE_WEBKIT_ARCH_SUPPORTS
depends on !BR2_BINFMT_FLAT # icu
depends on BR2_TOOLCHAIN_HAS_SYNC_4 # harfbuzz
select BR2_PACKAGE_CAIRO
select BR2_PACKAGE_CAIRO_PNG
select BR2_PACKAGE_ENCHANT
select BR2_PACKAGE_HARFBUZZ
select BR2_PACKAGE_ICU
select BR2_PACKAGE_JPEG
select BR2_PACKAGE_LIBCURL
select BR2_PACKAGE_LIBGAIL
select BR2_PACKAGE_LIBSECRET
select BR2_PACKAGE_LIBSOUP
select BR2_PACKAGE_LIBXML2
select BR2_PACKAGE_LIBXSLT
select BR2_PACKAGE_SQLITE
select BR2_PACKAGE_WEBP
select BR2_PACKAGE_XLIB_LIBXT if BR2_PACKAGE_XORG7
select BR2_PACKAGE_XLIB_LIBXCOMPOSITE if BR2_PACKAGE_HAS_LIBGL
select BR2_PACKAGE_XLIB_LIBXDAMAGE if BR2_PACKAGE_HAS_LIBGL
help
WebKit is an open source, standards compliant web browser engine.
Note that WebKit does not build with a toolchain using the
old linuxthreads library.
http://webkit.org/
comment "webkit needs libgtk2 and a toolchain w/ C++, wchar, threads"
depends on BR2_DEPRECATED_SINCE_2015_08
depends on BR2_PACKAGE_WEBKIT_ARCH_SUPPORTS
depends on BR2_TOOLCHAIN_HAS_SYNC_4
depends on !BR2_PACKAGE_LIBGTK2 || !BR2_INSTALL_LIBSTDCPP || \
!BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
depends on BR2_USE_MMU

View file

@ -1,2 +0,0 @@
# locally computed
sha256 51f808c96f52729dde6fb2b58752a6f623aeea74ff1ac6d4a1658720c6206fbe webkitgtk-1.11.5.tar.xz

View file

@ -1,72 +0,0 @@
################################################################################
#
# webkit
#
################################################################################
WEBKIT_VERSION = 1.11.5
WEBKIT_SITE = http://www.webkitgtk.org/releases
WEBKIT_SOURCE = webkitgtk-$(WEBKIT_VERSION).tar.xz
WEBKIT_INSTALL_STAGING = YES
WEBKIT_DEPENDENCIES = host-ruby host-flex host-bison host-gperf enchant harfbuzz \
icu jpeg libcurl libgail libsecret libsoup libxml2 libxslt libgtk2 sqlite webp
WEBKIT_DEPENDENCIES += \
$(if $(BR_PACKAGE_XLIB_LIBXCOMPOSITE),xlib_libXcomposite) \
$(if $(BR_PACKAGE_XLIB_LIBXDAMAGE),xlib_libXdamage)
# webkit-disable-tests.patch changes configure.ac therefore autoreconf required
WEBKIT_AUTORECONF = YES
WEBKIT_AUTORECONF_OPTS = -I $(@D)/Source/autotools
# parallel make install deadlocks with make 3.81
WEBKIT_INSTALL_STAGING_OPTS = -j1 DESTDIR=$(STAGING_DIR) install
WEBKIT_INSTALL_TARGET_OPTS = -j1 DESTDIR=$(TARGET_DIR) install
# Does not build and it's disabled by default
# in newer releases
define DISABLE_INDEXED_DATABASE
$(SED) '/ENABLE_INDEXED_DATABASE/s:1:0:' \
$(@D)/Source/WebCore/GNUmakefile.features.am
endef
WEBKIT_PRE_CONFIGURE_HOOKS += DISABLE_INDEXED_DATABASE
# Give explicit path to icu-config, and silence gazillions of warnings
# with recent gcc versions.
WEBKIT_CONF_ENV = ac_cv_path_icu_config=$(STAGING_DIR)/usr/bin/icu-config \
CFLAGS="$(TARGET_CFLAGS) -Wno-cast-align -Wno-sign-compare" \
CXXFLAGS="$(TARGET_CXXFLAGS) -Wno-cast-align -Wno-sign-compare" \
AR_FLAGS="cru"
WEBKIT_CONF_OPTS += \
--enable-dependency-tracking \
--with-gtk=2.0 \
--disable-geolocation \
--disable-webkit2 \
--disable-glibtest \
--disable-video \
--disable-tests
# Xorg Dependencies
WEBKIT_CONF_OPTS += --with-target=x11
WEBKIT_DEPENDENCIES += xlib_libXt
ifeq ($(BR2_PACKAGE_HAS_LIBEGL)$(BR2_PACKAGE_HAS_LIBGLES),yy)
WEBKIT_CONF_OPTS += --enable-gles2
WEBKIT_DEPENDENCIES += libegl libgles
else
WEBKIT_CONF_OPTS += --disable-gles2
endif
# gles/egl support is prefered over opengl by webkit configure
ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
WEBKIT_CONF_OPTS += --with-acceleration-backend=opengl
WEBKIT_DEPENDENCIES += libgl
else
# OpenGL/glx is auto-detected due to the presence of gl.h/glx.h, which is not
# enough, so disable glx and the use of the OpenGL acceleration backend here
WEBKIT_CONF_OPTS += --disable-glx --with-acceleration-backend=none
endif
$(eval $(autotools-package))