buildroot/package/axfsutils/0002-use-ldflags.patch
Yann E. MORIN cb8b5c27b2 package/axfsutils: fix Makefile
mkfs.axfs uses zlib, but does not have an rpath to our host dir.

That's because:
  - we're not passing our host CFLAGS or LDFLAGS
  - it is forcibly setting CFLAGS in the Makefile, overriding anything
    specified by the user
  - it is not using LDFLAGS at all

Add two patches so that CFLAGS and LDFLAGS from the environment are
used if present.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2015-11-17 09:29:24 +01:00

21 lines
608 B
Diff

Makefile: use LDFLAGS as provided by the user
In some circumstances, the user may want to pass some LDFLAGS, like
-L flags to point to the zlib location if it was not installed in a
standard location.
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
diff -durN a/mkfs.axfs-legacy/Makefile b/mkfs.axfs-legacy/Makefile
--- a/mkfs.axfs-legacy/Makefile
+++ b/mkfs.axfs-legacy/Makefile
@@ -6,7 +6,7 @@
all: mkfs.axfs
mkfs.axfs: $(MKFSOBJS)
- $(CC) $(CFLAGS) -o mkfs.axfs $(MKFSOBJS) -lz
+ $(CC) $(CFLAGS) $(LDFLAGS) -o mkfs.axfs $(MKFSOBJS) -lz
clean_mkfs.axfs:
rm -rf $(MKFSOBJS) mkfs.axfs