buildroot/package/ejabberd/0001-remove-make-targets-for-deps.patch
Johan Oudinet 35d46ba365 ejabberd: bump to version 17.04
There are new dependencies: erlang-p1-jiffy, erlang-p1-oauth2,
erlang-p1-stun, erlang-p1-tls, erlang-p1-utils, erlang-p1-xmpp

as well as two host dependencies on erlang-p1-utils and
erlang-p1-xmpp. Otherwise the compilation via rebar fails.

4 patches have been refreshed and a new patch have been introduced to
tell rebar to use host dependencies instead of trying to download them.
Hopefully this patch could be drop in ejabberd 17.06. Missing SoB in
patches have been added as well.

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2017-06-06 22:34:11 +02:00

43 lines
914 B
Diff

From 21d1f05a8882657c151397d0e4723535402f1757 Mon Sep 17 00:00:00 2001
From: Philipp Huebner <debalance@debian.org>
Date: Wed, 20 Jan 2016 10:22:57 -0500
Subject: [PATCH] remove make targets for deps
Without this patch, dependencies would be downloaded and compiled
using rebar at build time.
Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
diff --git a/Makefile.in b/Makefile.in
index a0b4553d..4190a515 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -77,26 +77,11 @@ else
INIT_USER=$(INSTALLUSER)
endif
-all: deps src
+all: src
-deps: deps/.got
-
-deps/.got:
- rm -rf deps/.got
- rm -rf deps/.built
- $(REBAR) get-deps && :> deps/.got
-
-deps/.built: deps/.got
- $(REBAR) compile && :> deps/.built
-
-src: deps/.built
+src:
$(REBAR) skip_deps=true compile
-update:
- rm -rf deps/.got
- rm -rf deps/.built
- $(REBAR) update-deps && :> deps/.got
-
xref: all
$(REBAR) skip_deps=true xref