buildroot/package/ghostscript/0002-Host-tool-mkromfs_1-needs-libz.patch
Bernd Kuhls 1a83dda003 package/ghostscript: new package
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Thomas:
 - switch to version 9.21 now that it has been released
 - add a hash file
 - switch to Git formatted patches
 - use $(HOSTCC) instead of hardcoding "gcc", and use $(HOST_CFLAGS) and
   $(HOST_LDFLAGS) instead of hardcoding -L$(HOST_DIR)/usr/lib
   -I$(HOST_DIR)/usr/include
 - add entry to DEVELOPERS file.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2017-03-20 23:54:43 +01:00

49 lines
1.9 KiB
Diff

From c9e370d7cdf1bb5fbbd5c1e7e9c5431f6112b074 Mon Sep 17 00:00:00 2001
From: Bernd Kuhls <bernd.kuhls@t-online.de>
Date: Mon, 20 Mar 2017 23:43:29 +0100
Subject: [PATCH] Host tool mkromfs_1 needs libz
Fixes build error
/tmp/ccckTW0s.o: In function `process_path':
mkromfs.c:(.text+0x2390): undefined reference to `compress'
/tmp/ccckTW0s.o: In function `process_initfile':
mkromfs.c:(.text+0x3616): undefined reference to `compress'
collect2: error: ld returned 1 exit status
base/unix-aux.mak:103: recipe for target 'obj/aux/mkromfs_1' failed
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
Makefile.in | 1 +
base/unix-aux.mak | 2 +-
2 files changed, 2 insertions(+), 1 deletion(-)
diff --git a/Makefile.in b/Makefile.in
index 3a3cae5..600ce3e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -461,6 +461,7 @@ XPS_LDFLAGS_SO=@XPS_DYNAMIC_LDFLAGS@
EXTRALIBS=$(XTRALIBS) @LIBS@ @DYNAMIC_LIBS@ @FONTCONFIG_LIBS@ @FT_LIBS@ @JPX_AUTOCONF_LIBS@ @EXPAT_LIBS@
AUXEXTRALIBS=@AUXEXTRALIBS@
+AUX_SHARED_ZLIB=@AUX_SHARED_ZLIB@
# Define the standard libraries to search at the end of linking.
# Most platforms require -lpthread for the POSIX threads library;
diff --git a/base/unix-aux.mak b/base/unix-aux.mak
index c5fa2a4..4ed8369 100644
--- a/base/unix-aux.mak
+++ b/base/unix-aux.mak
@@ -100,7 +100,7 @@ MKROMFS_OBJS_1=$(AUX)gscdefs.$(OBJ) \
$(AUX)gp_stdia.$(OBJ) $(AUX)gsutil.$(OBJ)
$(MKROMFS_XE)_1: $(GLSRC)mkromfs.c $(MKROMFS_COMMON_DEPS) $(MKROMFS_OBJS_1) $(UNIX_AUX_MAK) $(MAKEDIRS)
- $(CCAUX_) $(GENOPTAUX) $(I_)$(GLSRCDIR)$(_I) $(I_)$(GLOBJ)$(_I) $(I_)$(ZSRCDIR)$(_I) $(GLSRC)mkromfs.c $(O_)$(MKROMFS_XE)_1 $(MKROMFS_OBJS_1) $(AUXEXTRALIBS)
+ $(CCAUX_) $(GENOPTAUX) $(I_)$(GLSRCDIR)$(_I) $(I_)$(GLOBJ)$(_I) $(I_)$(ZSRCDIR)$(_I) $(GLSRC)mkromfs.c $(O_)$(MKROMFS_XE)_1 $(MKROMFS_OBJS_1) $(AUXEXTRALIBS) $(AUX_SHARED_ZLIB)
$(MKROMFS_XE): $(MKROMFS_XE)_$(SHARE_ZLIB) $(UNIX_AUX_MAK) $(MAKEDIRS)
$(CP_) $(MKROMFS_XE)_$(SHARE_ZLIB) $(MKROMFS_XE)
--
2.7.4