buildroot/package/iperf/0001-util.h-add-missing-stdbool-header.patch
Baruch Siach 11cc12eefd iperf: bump to version 2.0.9
iperf2 is a fork of the original unmaintained iperf project, that
continues the development of the iperf 2.x series. Update homepage
link, and download location.

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
[Thomas:
 - change the download location to use downloads.sourceforge.net
 - turn the patch into a Git-formatted one, since upstream uses Git as
   its version control system
 - as noticed by Khem Raj, a C99 compiler is needed for the bool type,
   so added AC_PROG_CC_C99 to configure.ac, and consequently added
   IPERF_AUTORECONF = YES.
 - removed two <pkg>_CONF_ENV variables related to the bool type, they
   were added by an older commit
   e13ac0ec87 back when we had a
   config.cache shared between packages (which is no longer the case
   today)]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2016-07-30 14:30:03 +02:00

55 lines
1.7 KiB
Diff
Raw Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

From babf9a5c2bbce4725963b21e47f413962e33ea88 Mon Sep 17 00:00:00 2001
From: Baruch Siach <baruch@tkos.co.il>
Date: Sat, 30 Jul 2016 14:24:33 +0200
Subject: [PATCH] util.h: add missing stdbool header
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
C requires the stdbool.h header for the 'bool' type.
Fixes the following build failure under uClibc-ng C library:
.../arm-linux-gcc -DHAVE_CONFIG_H -I. -I.. -I../include -I../include -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Wall -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -Os -c delay.c
In file included from delay.c:55:0:
../include/util.h:73:1: error: unknown type name bool
bool setsock_blocking(int fd, bool blocking);
^
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
[Thomas: add AC_PROG_CC_C99, since C99 is needed for the bool type.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
configure.ac | 1 +
include/util.h | 2 ++
2 files changed, 3 insertions(+)
diff --git a/configure.ac b/configure.ac
index d59107a..ba30cb7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,7 @@ dnl ===================================================================
AC_PROG_CXX
CXXFLAGS=`echo " $CXXFLAGS " | sed -e "s/ -g / /"` # do not want it implicitly
AC_PROG_CC
+AC_PROG_CC_C99
CFLAGS=`echo " $CFLAGS " | sed -e "s/ -g / /"` # do not want it implicitly
AC_ISC_POSIX
AC_PROG_INSTALL
diff --git a/include/util.h b/include/util.h
index f4ae3d8..91540a9 100644
--- a/include/util.h
+++ b/include/util.h
@@ -57,6 +57,8 @@
#include "config.h"
#endif
+#include <stdbool.h>
+
#ifdef __cplusplus
extern "C" {
#endif
--
2.7.4