buildroot/package/libtorrent/0001-cross_compile.patch
Vicente Olivert Riera 1376203719 libtorrent: bump to version 0.13.6
- Bump to version 0.13.6.

- Add a hash file.

- Change the website URL to the new official one.

- Help the build system to find the zlib headers, otherwise the
  configure script will fail like this:

    checking if zlib is wanted... yes
    checking for inflateEnd in -lz... no
    checking zlib.h usability... no
    checking zlib.h presence... no
    checking for zlib.h... no
    configure: error: either specify a valid zlib installation with
    --with-zlib=DIR or disable zlib usage with --without-zlib

- Disable instrumentation support by default since it avoids runtime
  failures on rtorrent for some architectures like MIPS, PowerPC or ARM:

    https://github.com/rakshasa/rtorrent/issues/156

- Tweak the 0001-cross_compile.patch for this new version.

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2015-10-05 02:09:43 +02:00

66 lines
2 KiB
Diff

From c4cc0ba76c81e1967c648be423f5f0312ac9d87f Mon Sep 17 00:00:00 2001
From: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Date: Mon, 5 Oct 2015 00:40:25 +0100
Subject: [PATCH] Fix cross compilation, based on OpenWRT patch.
[Vincent: tweak the patch for version 0.13.6]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
---
configure.ac | 1 -
scripts/checks.m4 | 2 +-
scripts/common.m4 | 4 ++--
3 files changed, 3 insertions(+), 4 deletions(-)
diff --git a/configure.ac b/configure.ac
index ba994ee..7696466 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,7 +19,6 @@ AC_SUBST(LIBTORRENT_INTERFACE_VERSION_NO)
AM_INIT_AUTOMAKE
AC_CONFIG_HEADERS(config.h)
-AM_PATH_CPPUNIT(1.9.6)
AC_PROG_CXX
diff --git a/scripts/checks.m4 b/scripts/checks.m4
index 598f39b..0e5abe0 100644
--- a/scripts/checks.m4
+++ b/scripts/checks.m4
@@ -96,7 +96,7 @@ AC_DEFUN([TORRENT_CHECK_KQUEUE], [
AC_DEFUN([TORRENT_CHECK_KQUEUE_SOCKET_ONLY], [
AC_MSG_CHECKING(whether kqueue supports pipes and ptys)
- AC_RUN_IFELSE([AC_LANG_SOURCE([
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
#include <fcntl.h>
#include <stdlib.h>
#include <unistd.h>
diff --git a/scripts/common.m4 b/scripts/common.m4
index 5127624..cc68269 100644
--- a/scripts/common.m4
+++ b/scripts/common.m4
@@ -223,7 +223,7 @@ dnl Need to fix this so that it uses the stuff defined by the system.
AC_DEFUN([TORRENT_CHECK_EXECINFO], [
AC_MSG_CHECKING(for execinfo.h)
- AC_RUN_IFELSE([AC_LANG_SOURCE([
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
#include <execinfo.h>
int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
])],
@@ -238,7 +238,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
AC_DEFUN([TORRENT_CHECK_ALIGNED], [
AC_MSG_CHECKING(the byte alignment)
- AC_RUN_IFELSE([AC_LANG_SOURCE([
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
#include <inttypes.h>
int main() {
char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 };
--
1.7.1