buildroot/package/poco/0001-poco-add-the-staging-path-to-search-path.patch
Jörg Krause a42c59dba1 package/poco: bump to version 1.6.1
Also:
  * switch from sourceforge to github
  * remove hash (github-helper)
  * remove upstream applied patches
  * re-number remaining patches
  * add patch to fix build issue with `--bundled` config option

[Thomas: really remove hash file, since we're fetching from Github.]

Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
2015-08-10 16:17:06 +02:00

39 lines
1.4 KiB
Diff

From b8417607ec8840e6a1e27cf03b6958c794a33e49 Mon Sep 17 00:00:00 2001
From: Baruch Siach <baruch@tkos.co.il>
Date: Tue, 4 Aug 2015 10:14:00 +0200
Subject: [PATCH 1/2] poco: add the staging path to search path
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Add the mysql headers and client libraries to the search path of the
preprocessor and the linker. The $MYSQL_LIBDIR / $MYSQL_INCIDR variables
must be set from the make command line.
[Peter: Remove host dirs, add MYSQL_INCDIR]
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
[Jörg: Update to version 1.6.1 from github]
Signed-off-by: Jörg Krause <joerg.krause@embedded.rocks>
---
Data/MySQL/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/Data/MySQL/Makefile b/Data/MySQL/Makefile
index 0b18ca5..094e807 100644
--- a/Data/MySQL/Makefile
+++ b/Data/MySQL/Makefile
@@ -8,8 +8,8 @@
include $(POCO_BASE)/build/rules/global
-SYSLIBS += -L/usr/local/lib$(LIB64SUFFIX)/mysql -L/usr/lib$(LIB64SUFFIX)/mysql -L/usr/mysql/lib$(LIB64SUFFIX) -L/usr/mysql/lib$(LIB64SUFFIX)/mysql -L/usr/local/mysql/lib$(LIB64SUFFIX) -lmysqlclient
-INCLUDE += -I/usr/local/include/mysql/ -I/usr/include/mysql/ -I/usr/mysql/include/mysql -I/usr/local/mysql/include
+SYSLIBS += -L$(MYSQL_LIBDIR) -lmysqlclient
+INCLUDE += -I$(MYSQL_INCDIR)
SYSFLAGS += -DTHREADSAFE -DNO_TCL
objects = Binder Extractor SessionImpl Connector \
--
2.5.0