buildroot/package/efl/0001-ecore_evas-engines-drm-meson.build-use-gl_deps-as-en.patch
Romain Naour cf57eceabc package/efl: bump to version 1.25.0
Remove 0001-doc-meson.build-add-single-quote-for-env.patch superseeded
by https://git.enlightenment.org/core/efl.git/commit/?id=e2a1cdfda76dd0061ef8e0ab25aee4e042304366

Rename luajit bindings to lua after upstream rework to support lua interpreter
(non-luajit):

https://git.enlightenment.org/core/efl.git/commit/?id=5197200ac1d49366f205a62a09a377fdece62ff9
https://git.enlightenment.org/core/efl.git/commit/?id=b0203b3160f2a39c3afe549fd34a513f71532fc3
https://git.enlightenment.org/core/efl.git/commit/?id=f78d54051c26a8d3c9b3bfc61e44df09bf24e401
https://git.enlightenment.org/core/efl.git/commit/?id=6dce869a17baae6002c3cec04e975c0730461a00

For now keep the luajit dependency as is. lua support can be enabled by a followup patch.

Disable the new avif evas loader and saver added by:
https://git.enlightenment.org/core/efl.git/commit/?id=fd24e89144d8808e4e7ee20efe599ff4a6d3d37e

Remove elogind meson option removed by:
https://git.enlightenment.org/core/efl.git/commit/?id=fe56edae3f5015c62e319d5e2ab2552d3533eead

See:
https://www.enlightenment.org/news/efl-1.25.0

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-10-06 21:28:18 +02:00

37 lines
1.3 KiB
Diff

From 51dfe1863ddc8c5dd576405a9bbb8bca875c1142 Mon Sep 17 00:00:00 2001
From: Romain Naour <romain.naour@gmail.com>
Date: Sat, 1 Aug 2020 02:25:47 +0200
Subject: [PATCH] ecore_evas/engines/drm/meson.build: use "gl_deps" as engine
dependencies
Meson trigger an error since "engine_gl_drm" variable doesn't exist.
src/modules/ecore_evas/engines/drm/meson.build:10:2: ERROR: Unknown variable "engine_gl_drm".
Instead use "gl_deps" as engine dependencies.
Upstream status:
https://sourceforge.net/p/enlightenment/mailman/message/37075016/
Signed-off-by: Romain Naour <romain.naour@gmail.com>
---
src/modules/ecore_evas/engines/drm/meson.build | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/modules/ecore_evas/engines/drm/meson.build b/src/modules/ecore_evas/engines/drm/meson.build
index 58071010d0..0741d7fccd 100644
--- a/src/modules/ecore_evas/engines/drm/meson.build
+++ b/src/modules/ecore_evas/engines/drm/meson.build
@@ -3,7 +3,7 @@ engine_deps = [ecore_drm2, ecore_input, eeze, elput, libdrm, engine_drm]
if get_option('opengl') != 'none'
config_h.set('BUILD_ECORE_EVAS_GL_DRM', '1')
- engine_deps += [engine_gl_drm]
+ engine_deps += [gl_deps]
endif
engine_include_dir += include_directories(join_paths('..', '..', '..', 'evas', 'engines', 'drm'))
--
2.25.4