buildroot/package/flite/0001-fix-alsa-static.patch
Fabrice Fontaine 604c858c22 package/flite: bump to version 2.1
- Update site to get latest version
- First patch is not needed since
  e7e4868ad7
- Update second patch
- Drop third patch (not needed anymore)
- Update hash of COPYING:
  - BSD-2-Clause for Palm source code removed
  - Add SUN Microsystems license for g72x files
  - Add Apache-2.0 for lang/cmu_grapheme_lex/grapheme_unitran_tables.c
- Update indentation of hash file (two spaces)

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
2020-04-07 07:49:08 +02:00

20 lines
781 B
Diff

Use pkg-config to determine alsa link flags. This fixes static linking.
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
diff -Nuar flite-1.4-release.orig/configure.in flite-1.4-release/configure.in
--- flite-1.4-release.orig/configure.in 2009-08-14 23:46:38.000000000 +0300
+++ flite-1.4-release/configure.in 2014-04-30 18:52:33.253297236 +0300
@@ -275,7 +275,10 @@
#endif],
[AUDIODRIVER="alsa"
AUDIODEFS=-DCST_AUDIO_ALSA
- AUDIOLIBS=-lasound])
+ AUDIOLIBS=`pkg-config --libs alsa`
+ if test "$shared" = false; then
+ AUDIOLIBS=`pkg-config --libs --static alsa`
+ fi])
AC_CHECK_HEADER(mmsystem.h,
[AUDIODRIVER="wince"
AUDIODEFS=-DCST_AUDIO_WINCE