buildroot/package/kmsxx/0001-meson-add-use-system-fmt-option.patch
Peter Seiderer 4146241624 package/kmsxx: bump version to 5489056 and convert to meson build
- remove 0001-fix-compiler-errors-with-gcc-10.patch
  (upstream)

- remove 0002-added-include-string-to-card.h-to-follow-gcc10-porti.patch
  (upstream)

- convert to meson

- add patch to use system fmt instead of git submodule (fixes
  configure 'ERROR: Include dir ext/fmt/include does not exist.')

- add patch to use system pybind11 instead of git submodule (fixes
  configure 'ERROR: Include dir ext/pybind11/include does not exist.')

- add patch to use python only if pykms is enabled (fixes
  configure 'ERROR: Dependency "pybind11" not found, tried pkgconfig')

- add optional libevdev dependency (needed for utils/kmstouch)

- update LICENSE file hash (replaced short copyright notice and
  link to  http://mozilla.org/MPL/2.0/ with complete license text)

- lift toolchain headers requirement to at least 4.11 (include
  linux/dma-buf.h)

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-12-01 22:47:29 +01:00

47 lines
1.6 KiB
Diff

From 61db7d5520f50564da8f2c9ac952eadb31f70727 Mon Sep 17 00:00:00 2001
From: Peter Seiderer <ps.report@gmx.net>
Date: Sun, 29 Nov 2020 11:13:41 +0100
Subject: [PATCH] meson: add use-system-fmt option
[Upstream: https://github.com/tomba/kmsxx/pull/60]
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
meson.build | 10 +++++++---
meson_options.txt | 2 ++
2 files changed, 9 insertions(+), 3 deletions(-)
diff --git a/meson.build b/meson.build
index 9652009..29080f4 100644
--- a/meson.build
+++ b/meson.build
@@ -31,9 +31,13 @@ endif
add_global_link_arguments(link_arguments, language : 'cpp')
-libfmt_includes = include_directories('ext/fmt/include')
-libfmt_dep = declare_dependency(include_directories : libfmt_includes,
- compile_args : '-DFMT_HEADER_ONLY')
+if get_option('use-system-fmt')
+ libfmt_dep = dependency('fmt')
+else
+ libfmt_includes = include_directories('ext/fmt/include')
+ libfmt_dep = declare_dependency(include_directories : libfmt_includes,
+ compile_args : '-DFMT_HEADER_ONLY')
+endif
pybind11_includes = include_directories('ext/pybind11/include')
pybind11_dep = declare_dependency(include_directories : pybind11_includes)
diff --git a/meson_options.txt b/meson_options.txt
index cd854ab..48176a8 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -3,3 +3,5 @@ option('pykms', type : 'feature', value : 'auto')
option('omap', type : 'feature', value : 'auto')
option('static-libc', type : 'boolean', value : false)
option('utils', type : 'boolean', value : true)
+
+option('use-system-fmt', type : 'boolean', value : false)
--
2.29.2