buildroot/package/kmsxx/0003-meson-only-build-py-in-case-pykms-is-enabled.patch
Peter Seiderer 4146241624 package/kmsxx: bump version to 5489056 and convert to meson build
- remove 0001-fix-compiler-errors-with-gcc-10.patch
  (upstream)

- remove 0002-added-include-string-to-card.h-to-follow-gcc10-porti.patch
  (upstream)

- convert to meson

- add patch to use system fmt instead of git submodule (fixes
  configure 'ERROR: Include dir ext/fmt/include does not exist.')

- add patch to use system pybind11 instead of git submodule (fixes
  configure 'ERROR: Include dir ext/pybind11/include does not exist.')

- add patch to use python only if pykms is enabled (fixes
  configure 'ERROR: Dependency "pybind11" not found, tried pkgconfig')

- add optional libevdev dependency (needed for utils/kmstouch)

- update LICENSE file hash (replaced short copyright notice and
  link to  http://mozilla.org/MPL/2.0/ with complete license text)

- lift toolchain headers requirement to at least 4.11 (include
  linux/dma-buf.h)

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2020-12-01 22:47:29 +01:00

49 lines
1.4 KiB
Diff

From 0ef36b2e22c2ac0331b3096b7adc69fb08044048 Mon Sep 17 00:00:00 2001
From: Peter Seiderer <ps.report@gmx.net>
Date: Sun, 29 Nov 2020 11:37:26 +0100
Subject: [PATCH] meson: only build py in case pykms is enabled
[Upstream: https://github.com/tomba/kmsxx/pull/60]
Signed-off-by: Peter Seiderer <ps.report@gmx.net>
---
meson.build | 16 ++++++++++------
1 file changed, 10 insertions(+), 6 deletions(-)
diff --git a/meson.build b/meson.build
index 4b3e7c3..1810b17 100644
--- a/meson.build
+++ b/meson.build
@@ -39,11 +39,13 @@ else
compile_args : '-DFMT_HEADER_ONLY')
endif
-if get_option('use-system-pybind11')
- pybind11_dep = dependency('pybind11')
-else
- pybind11_includes = include_directories('ext/pybind11/include')
- pybind11_dep = declare_dependency(include_directories : pybind11_includes)
+if get_option('pykms').enabled()
+ if get_option('use-system-pybind11')
+ pybind11_dep = dependency('pybind11')
+ else
+ pybind11_includes = include_directories('ext/pybind11/include')
+ pybind11_dep = declare_dependency(include_directories : pybind11_includes)
+ endif
endif
libdrmomap_dep = dependency('libdrm_omap', required : get_option('omap'))
@@ -55,7 +57,9 @@ if get_option('utils')
subdir('utils')
endif
-subdir('py')
+if get_option('pykms').enabled()
+ subdir('py')
+endif
if get_option('kmscube')
subdir('kmscube')
--
2.29.2